Closed Bug 1793508 Opened 4 months ago Closed 4 months ago

RFP letterboxing causes overflow in main browser area below ~800px width

Categories

(Firefox :: Theme, defect)

All
Linux
defect

Tracking

()

VERIFIED FIXED
107 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox105 --- unaffected
firefox106 --- unaffected
firefox107 --- verified

People

(Reporter: kevin, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Using Firefox Nightly build 20221002212226 with privacy.resistFingerprinting.letterboxing:true, if the browser window has a width less than ~800px, the toolbars and content window can get cut off along the right edge (e.g. the main menu hamburger button can get cut off). The issue appears to occur under a variety of condition. It does appear to be affected by the content of the displayed page. One reliable reproduction I've used:

  1. Open a new browser window and resize it to 800px wide.
  2. Navigate to https://git-scm.com/docs/git-config
  3. Find in page (Ctrl+F) "safe."

When the "." of "safe." is entered in the search box, letterboxing appears along the left side of the browser window and overflow occurs along the right, cutting off the main menu button and the right edge of the page content.

I'm able to reproduce the issue on Sway and Mutter using either a native Wayland window or XWayland window. Bisection with mozregression --pref privacy.resistFingerprinting.letterboxing:true --arg https://git-scm.com/docs/git-config gives pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=dd74d4159c5dfa4307f663df24cf64766a4d5781&tochange=61cde6b6f2737eee00c49fb75390aff3d814f677 suggesting this was regressed by Bug 1789168.

Has STR: --- → yes
Keywords: regression
Regressed by: 1789168

:emilio, since you are the author of the regressor, bug 1789168, could you take a look? Also, could you set the severity field?

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)
Assignee: nobody → emilio
Flags: needinfo?(emilio)

So that its contents don't influence the automatic minimum size of the
tab panels. This matches the previous XUL layout behavior.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/01823fe27084
Contain inline-size of findbar. r=aminomancer
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch
QA Whiteboard: [qa-107b-p2]

I managed to reproduce this issue on a 2022-10-02 Nightly build on Ubuntu 22 using the STR from the Description. Verified as fixed on Firefox 107.0b4(build ID: 20221023190001), Nightly 108.0a1(build ID: 20221023100414) on Ubuntu 22, macOS 12, Windows 10.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-107b-p2]
You need to log in before you can comment on or make changes to this bug.