Selection is printed out badly positioned and incompletely

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: relf, Assigned: rods)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
OS/2 build 2002110812

To reproduce:
1. Go to the provided URL
2. Select lyrics "Where The Wild Roses Grow" (right under album picture)
3. Print out the selection

Actual result:
Printing takes one page.
The printed text starts at bottom of the page.
Although text does not fit the page, it's not continued on another page.

Printing result in .ps is coming.
(Reporter)

Comment 1

16 years ago
Created attachment 105751 [details]
Printed result (.ps.gz)

The printed result in postscript

Comment 2

16 years ago
I did a search for my bug report, and found this one closest to what I want to
report. Please let me know / file a new bug, if this is not where this should go:

I have a 3 page printout of a web page. I selected some text, and printed it.
Only half (first) of the text got printed. I tried it again, same thing.

Then, I noticed that the selection that I had made was starting at the end of
the 1st sheet, continuing to the begninning ot the 2nd sheet of the complete
printout.

It seems that if I print a selection that should have been printed in multiple
pages on a complete printout, only the part which is on the initail page gets
printed.

Fails on Linux and XP:
On Linux: 2003021605
OnXP: 20030224nn (don't remember the last 2 digits)

Thanks

Ajay Gautam

Comment 3

16 years ago
This is a very annoying bug for me, because I print long news articles all the
time by using the "print selection" option under the print submenu. Usually in a
long article, it only prints the first page. Occasionally it will print the
whole thing but will chop off part of the text at the bottom of the page.

Comment 4

15 years ago
I tried this on linux (build ID 20041230). In the printout, the selected lyrics
started at the top of the page and fit entirely on the first page of the printout.

There are lyrics for other songs following "Where The Wild Roses Grow", so I
selected the lot and printed that. This resulted in a three-page printout. All
of the text was printed, but the last line of text on pages 1 & 2 was cropped
short, with the missing pixels appearing as the first line of text on the next page.

This isn't perfect--mozilla shouldn't be splitting a single line of text over
two pages--but it's different from the behavior described in the original report.

Max, could you try this with a current copy of mozilla and see how it behaves
for you?

Comment 5

14 years ago
Printing selection prints selection as it appeared on the page originally, not
independant of the original document. As a result, text appears skewif on the paper.
(Reporter)

Comment 6

14 years ago
Yeah, now it prints much better.
Splitting a text line between pages is a different issue (bug 240625).
Marking this bug as WFM.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.