Closed Bug 1793703 Opened 2 years ago Closed 2 years ago

"Site Permissions" should be capitalized in generated add-on

Categories

(Toolkit :: Add-ons Manager, task)

task

Tracking

()

RESOLVED FIXED
107 Branch
Tracking Status
firefox107 --- fixed

People

(Reporter: bholley, Assigned: willdurand)

References

Details

(Whiteboard: [addons-jira])

Attachments

(1 file)

An unscientific survey indicates that addon titles tend to Capitalize Each of the Major Words. In contrast, the generated addons are currently called "Site permissions". This looks a bit weird, and also causes us to print the prompt message:

"Add Site permissions for foo.bar.com?"

I think we should capitalize "Permissions" to make this:

"Add Site Permissions for foo.bar.com?"

This looked like a straightforward enough change so I submitted a patch, no need for multiple reviewers.

Assignee: nobody → wdurand
Status: NEW → ASSIGNED
Pushed by wdurand@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9871c46ce197
Capitalize generated site permission add-on title. r=rpl

Backed out for causing failures on browser_addon_list_reordering.js

[task 2022-10-05T18:40:30.003Z] 18:40:30     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_addon_list_reordering.js | cardThree is now in enabled - 
[task 2022-10-05T18:40:30.004Z] 18:40:30     INFO - Console message: [JavaScript Warning: "Key event not available on some keyboard layouts: key=“r” modifiers=“accel,alt” id=“key_toggleReaderMode”" {file: "chrome://mochikit/content/tests/SimpleTest/EventUtils.js" line: 1360}]
[task 2022-10-05T18:40:30.005Z] 18:40:30     INFO - Console message: [JavaScript Warning: "Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox”" {file: "chrome://mochikit/content/tests/SimpleTest/EventUtils.js" line: 1360}]
[task 2022-10-05T18:40:30.011Z] 18:40:30     INFO - Console message: 1664995229187	addons.xpi	DEBUG	Updating XPIState for {"id":"one@mochi.test","syncGUID":"{b34bc979-9ff9-495d-ad80-4cbdfdfce3dd}","version":"1.0","type":"extension","loader":null,"updateURL":null,"installOrigins":null,"manifestVersion":2,"optionsURL":null,"optionsType":null,"optionsBrowserStyle":true,"aboutURL":null,"defaultLocale":{"name":"one@mochi.test","creator":null,"developers":null,"translators":null,"contributors":null},"visible":true,"active":true,"userDisabled":true,"appDisabled":false,"embedderDisabled":false,"installDate":1664995226434,"updateDate":1664995226324,"applyBackgroundUpdates":1,"path":"/tmp/generated-extension.xpi","skinnable":false,"sourceURI":null,"releaseNotesURI":null,"softDisabled":false,"foreignInstall":false,"strictCompatibility":true,"locales":[],"targetApplications":[{"id":"toolkit@mozilla.org","minVersion":null,"maxVersion":null}],"targetPlatforms":[],"signedState":0,"signedDate":null,"seen":true,"dependencies":[],"incognito":"spanning","userPermissions":{"permissions":[],"origins":[]},"optionalPermissions":{"permissions":[],"origins":[]},"icons":{},"iconURL":null,"blocklistState":0,"blocklistURL":null,"startupData":null,"hidden":false,"installTelemetryInfo":null,"recommendationState":null,"rootURI":"jar:file:///tmp/generated-extension.xpi!/","location":"app-temporary"}
[task 2022-10-05T18:40:30.012Z] 18:40:30     INFO - Console message: 1664995229188	addons.xpi-utils	DEBUG	Updating active state for add-on one@mochi.test to false
[task 2022-10-05T18:40:30.013Z] 18:40:30     INFO - Console message: 1664995229190	addons.xpi	DEBUG	Calling bootstrap method shutdown on one@mochi.test version 1.0
[task 2022-10-05T18:40:30.013Z] 18:40:30     INFO - Buffered messages finished
[task 2022-10-05T18:40:30.015Z] 18:40:30     INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/browser/browser_addon_list_reordering.js | cardOne is still in enabled - Got "extension-disabled-heading", expected "extension-enabled-heading"
[task 2022-10-05T18:40:30.015Z] 18:40:30     INFO - Stack trace:
[task 2022-10-05T18:40:30.015Z] 18:40:30     INFO - chrome://mochikit/content/browser-test.js:test_is:1485
[task 2022-10-05T18:40:30.015Z] 18:40:30     INFO - chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_addon_list_reordering.js:assertInSection:15
[task 2022-10-05T18:40:30.015Z] 18:40:30     INFO - chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_addon_list_reordering.js:testReordering:172
[task 2022-10-05T18:40:30.016Z] 18:40:30     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_addon_list_reordering.js | cardThree is still in enabled - 
Flags: needinfo?(wdurand)

:nataliaCs I am not really sure this test can be affected by the patch I landed earlier. It looks like this test is an intermittent, see Bug 1683448. Any chance to re-land this patch as is? Or what is the process in this case?

Flags: needinfo?(wdurand) → needinfo?(ncsoregi)

William, my apologies.
It seems that the failure on card one that was actually permafailing was caused by an earlier push.
I will have the patch relanded.

Flags: needinfo?(ncsoregi)
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aa00d1ed6d85
Capitalize generated site permission add-on title. r=rpl a=reland
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch
Whiteboard: [addons-jira]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: