Closed Bug 1794180 Opened 2 months ago Closed 2 months ago

Links on Release Notes page opened as TB tab don't work

Categories

(Thunderbird :: General, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102+ affected)

RESOLVED FIXED
107 Branch
Tracking Status
thunderbird_esr102 + affected

People

(Reporter: b4, Assigned: rjl)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/105.0.0.0 Safari/537.36

Steps to reproduce:

Open Release Notes via "Help > About Thunderbird", Release Notes. Release Notes are displayed in TB tab. Now click on any link on the page (except Changes, Bug Fixes, All Releases).

Actual results:

Page goes blank, link isn't opened.

Expected results:

In 91, the page was shown in TB, but it would possibly be OK to launch it in the external browser.

Blocks: tb102found
Keywords: regression

Semi-confirmed with Thunderbird 102.3.2.

It looks like it's links that are not hosted on www.thunderbird.net that are problematic.

Broken links include:

  • "Tell us what you think" is on support.mozilla.org
  • "file a bug in Bugzilla" is on bugzilla.m.o.
  • donate button (give.thunderbird.net)
  • "Blog" (blog.thunderbird.net)

https://searchfox.org/comm-central/rev/c2de20c00273b0d8795bc2f9b316bc0a37ef5290/mail/base/content/specialTabs.js#877,879-880 - sounds like single-site is used. I would argue this should just always open in the external browser.

Yeah, we should just open it in the external browser. It's not doing us any favors to open it in Thunderbird when somebody might want to click on other links leading to who knows what URLs and domains.

Opening in a mailtab caused problems with links on the release notes page going
to hosts other than www.thunderbird.net due to "single-site" being used. Notably,
the "Donate" button didn't work.

Assignee: nobody → rob
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Changing the "label" xul element over to an "html:a" with a click handler will open the notes in a browser. The openLink() function is used elsewhere in the About page. The "href" attribute for the link element was already being added when it was a "xul:label", and continues to do so.

Testing with a Daily build won't work... there's no release notes to link to, so the link stays hidden. The next merge to beta is Oct 17, verification can happen then. For review purposes, this try build should work: https://treeherder.mozilla.org/jobs?repo=try-comm-central&revision=9750d9bb5b8c489e24fdc8fc34e9cbb2809c6578 (106.0b5 + this patch).

Target Milestone: --- → 107 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/cddf205e196e
Open "Release Notes" link in web browser rather than a mailtab. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.