Closed Bug 179483 Opened 19 years ago Closed 18 years ago

Displays wrong product name in question of bug entry template for Chimera or Bugzilla

Categories

(Bugzilla :: User Interface, defect)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: Xapplimatic, Assigned: gerv)

References

()

Details

(Keywords: polish)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6

Section labelled Expected Results asks "What should Mozilla have done instead?".
The question is inappropriate especially being that the top of the form says
clearly that the Product is either Bugzilla or Mozilla embedded in the page code.

Reproducible: Always

Steps to Reproduce:
1. Enter non-Mozilla bug report in bugilla.mozilla.org tracked components.
2. Scroll down to Expected Results..
3. Tadah!

Actual Results:  
Always squawks "What should Mozilla have done instead" like a parrot.. 

Expected Results:  
Bugzilla should ask "What should (product name) have done instead?" --nobrainer.


Here is the section of bug entry template that needs to be fixed in both cases:
 
  <tr>
    <td valign="middle" align="right">
      <b>Expected Results</b> 
    </td>
    <td valign="top">
      <p>
        What should Mozilla have done instead?
      </p>
      <textarea rows="4" cols="80" name="expected_results" 
                wrap="hard"></textarea>
    </td>
  </tr>

Since there is already a different template for each product, it doesn't make
sense that this item wasn't changed to match the name of each product.  It will
take little work at all to patch this, just some minor text edits and ftp up the
patched pages to the Bugilla mothership!
Keywords: polish, ui
gerv owns the helper.

Should these bugs be filed on bugzilla or m.o, btw?

At the very least, we need to drop the 'please customise this' text.
Assignee: myk → gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
Yes, this is a valid bug. I'll do a patch tonight to make it use [% product %]
instead of Mozilla.

bbaetz' issue tracked as bug 179486.

Gerv
Attached patch Patch v.1Splinter Review
This patch makes the Bugzilla Helper a little more generic, now that it can be
used for any product.

Gerv
Attachment #105889 - Flags: review?(bbaetz)
Comment on attachment 105889 [details] [diff] [review]
Patch v.1

Hmm. 'The software' is sort of vague.

Can't we use the product name instead?

Of course, you then end up with 'Mozilla.org crashes, hangs, or ....', which is
a bit silly. OTOH, thats not software either, so its no less silly
Attachment #105889 - Flags: review?(bbaetz) → review-
> Of course, you then end up with 'Mozilla.org crashes, hangs, or ....', which is
> a bit silly. OTOH, thats not software either, so its no less silly.

It is more silly. "The software crashes..." is merely inappropriate.
"mozilla.org crashes" is gramatically and generally silly.

Other suggestions welcome, but I can't see a better way of improving the wording
without removing all explanatory text, or starting to fork the template. We
could change the hack to force the template only for certain products, but then
things start getting complicated.

Gerv
I don't know. I'm not too fussed over it, mind you.

Ccing people for comments?
bbaetz: no-one seems to care. So can we go with my wording? :-)

Gerv
How about "The product in question crashes, hangs, "etc...
Just generify it where it's silly to use the name...
Comment on attachment 105889 [details] [diff] [review]
Patch v.1

Yeah, ok. Lets go with your wording until someone complains.

(gerv: you should cc me when responding to my comments, wicn I cna't do so from
the attachment screen yet ;)
Attachment #105889 - Flags: review- → review+
Looks good.
Flags: approval+
Only justdave/myk get to approve bugzilla bugs....
Flags: approval+
sure, works for me.
Flags: approval+
Lol.. maybe the fact that the reporter can flag the review +, -, or ? is itself
another bug that should be reported then.. or is it just this implementation of
bugzilla? :)

The Flags:(Help!) file is not too helpful to a new user of Bugzilla, it makes
assumptions about past knowledge of prior versions and to a new user sounds like
if flags are intended only for a specific person, their name is put to the right
of the drop-down.. Here's the confusing line:
 
"Finally, statuses are preceded by the abbreviated email address (nick) of the
person granting the status and succeeded by the nick of the person who has been
asked to set the status (if any). "

Hence if there isn't a name to the right, it sounds like its open to all..
Hmm. The activity log of this bug doesn't seem to be recording the resetting of
the approval status...

Gerv
Fixed.

Checking in template/en/default/bug/create/create-guided.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/create-guided.html.tmpl,v
 <--  create-guided.html.tmpl
new revision: 1.4; previous revision: 1.3
done

Gerv
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.