Closed Bug 1795294 Opened 1 year ago Closed 1 year ago

In the toolbar items, you can't scroll inside the bookmarks folders when needed

Categories

(Firefox :: Theme, defect)

Firefox 107
defect

Tracking

()

VERIFIED FIXED
107 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox106 --- unaffected
firefox107 --- fixed

People

(Reporter: tgnff242, Assigned: emilio)

References

(Regression)

Details

(Keywords: crash, nightly-community, regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:107.0) Gecko/20100101 Firefox/107.0

Steps to reproduce:

  1. Create a bookmarks folder with as many items as needed for them to not fit vertically on the screen.
  2. Access it through the "Bookmarks toolbar items".

Actual results:

It's not possible to scroll down to see the rest of the bookmarks.

Expected results:

This is a regression from Bug 1790616.

Has STR: --- → yes
Component: Untriaged → Theme
Regressed by: 1790616
Flags: needinfo?(emilio)
Assignee: nobody → emilio
Flags: needinfo?(emilio)

I can also just drop min-width/height: 0 in the inline style if you'd
rather do that.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d65338d98d46
Allow places menupopups to shrink under the available size. r=dao
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Please provide ui automate test where used the modern flexbox.
There were so many regression ui due to replaced the modern flexbox :(

If there are too many bookmarks (1000+) in a menupopup, browser crashes(Bug 1705002) when the menu popup is opened.
bp-692aba3d-b2fc-4c59-83ce-6bf240221014

Keywords: crash
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch

Set release status flags based on info from the regressing bug 1790616

Flags: qe-verify+
Status: RESOLVED → VERIFIED

The issue is verified as fixed across platforms(Windows 10x64, macOS 10.12.6 and Ubuntu 18.4) Firefox 107.0b3 and Nightly 108.0a1. Removing the qe+ flag.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.