[ps] Default solaris print command should call "lp"

RESOLVED FIXED in Future

Status

()

P4
normal
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: gonufer, Assigned: kherron+mozilla)

Tracking

Trunk
Future
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3a) Gecko/20021110
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3a) Gecko/20021110

lpr is part of the optional UCB/Solaris 1.x compatability packages that are not
guaranteed to be installed on all SunOS 5.x systems.  Mozilla printing does not
work by default on systems without those optional compatability packages
installed.  Note that the packages are for compatability with an OS that hasn't
shipped for many years.


Reproducible: Always

Steps to Reproduce:
1. try to print anything from mozilla
2.
3.

Actual Results:  
Nothing.


Expected Results:  
Something being printed.
(Reporter)

Comment 1

16 years ago
Created attachment 105858 [details] [diff] [review]
workaround for systems that use lp instead of lpr

This is NOT a fix, it's just the changes I made for my SunOS 5 builds.	It will
break systems that use lpr and do not have lp.

Comment 2

16 years ago
Mhhh, the quiz is how to fix that ?
The default is set via unix.js - we would need a way to do somelike like this in
JavaScript:
-- snip --
#ifdef __sun
#define DEFINE_DEFAULT_SPOOLER "/usr/bin/lp"
#else
#define DEFINE_DEFAULT_SPOOLER "/usr/bin/lpr"
#endif
-- snip --

Any ideas ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: SunOS → Solaris
Summary: lpr is not guaranteed to exist on SunOS 5.x systems, lp is guaranteed to exist and should be used instead → [ps] lpr is not guaranteed to exist on SunOS 5.x systems, lp is guaranteed to exist and should be used instead

Comment 3

16 years ago
Well, a working workaround would be to use Xprint instead ("Xprt" on Solaris 2.x
uses /usr/bin/lp since eternity :) ...
(Reporter)

Comment 4

16 years ago
The real pseudo code should look more like this:

#ifdef __sysv
#define DEFINE_DEFAULT_SPOOLER "lp"
#else
#define DEFINE_DEFAULT_SPOOLER "lpr"
#endif

since SunOS 4.x systems, if anyone were to be foolish enough to port mozilla to
them, use lpr and should also satisfy the __sun condition.  Note that the
spooler arguments also change.

Comment 5

16 years ago
Greg Onufer wrote:
> The real pseudo code should look more like this:
[snip]

OK, but that still does not solve my main headache:
How to get this implemented in JavaScript ?
Priority: -- → P4
Target Milestone: --- → Future
(Assignee)

Comment 6

14 years ago
This should be pretty easy to fix now. Since this bug was written, all of the
default prefs have been moved into libpref/src/init/all.js, which goes through a
preprocessing phase that specifically supports per-OS defaults.
Assignee: rods → printing
QA Contact: sujay
Summary: [ps] lpr is not guaranteed to exist on SunOS 5.x systems, lp is guaranteed to exist and should be used instead → [ps] Default solaris print command should call "lp"
(Assignee)

Comment 7

14 years ago
Created attachment 177016 [details] [diff] [review]
Different print_command prefs for solaris

This sets alternate defaults for the prefs "print.print_command" and
"print.postscript.print_command" for solaris. I've tested this with a fresh
profile; the new print command shows up in the print dialog, and I can still
print.

There's no good reason to have two separate prefs for this. We should probably
standardize on "print.postscript.print_command". But that's an issue for
another day.

Does a patch like this require sr?
Assignee: printing → kherron+mozilla
Attachment #105858 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #177016 - Flags: review?(alecf)

Comment 8

14 years ago
Comment on attachment 177016 [details] [diff] [review]
Different print_command prefs for solaris

huh? I don't remember #ifdef's working in all.js, unless we're now
pre-processing it. This isn't C.
Attachment #177016 - Flags: review?(alecf) → superreview-

Comment 9

14 years ago
Comment on attachment 177016 [details] [diff] [review]
Different print_command prefs for solaris

sorry, my bad on the preprocessing..
Attachment #177016 - Flags: superreview- → superreview+
(Assignee)

Comment 10

14 years ago
Comment on attachment 177016 [details] [diff] [review]
Different print_command prefs for solaris

Requesting approval to check in. This just changes a couple of default prefs
for solaris.
Attachment #177016 - Flags: approval1.8b2?
Comment on attachment 177016 [details] [diff] [review]
Different print_command prefs for solaris

a=asa
Attachment #177016 - Flags: approval1.8b2? → approval1.8b2+
(Assignee)

Comment 12

14 years ago
Checked in. Resolving FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.