Calendar causes moz to chew 100% CPU when editing event

RESOLVED FIXED

Status

Calendar
General
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: Dave O'Neill, Assigned: Mike Potter)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021017
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021017

When attempting to edit an event (via either right-click and "Edit Selected
Event" or double-click), Mozilla CPU usage (as measured by 'top' on Linux) jumps
to 90%-100%, and persists at this usage after event editing is complete. 

Reproducible: Always

Steps to Reproduce:
1. Select event to edit
2. Double-click or right-click and "Edit Selected Event"
3. Check CPU utilization of mozilla-bin process via 'top' or other monitoring
program.

Actual Results:  
Event is created correctly, but CPU usage by Mozilla is now near 100% and
remains there until the calendar window is closed.

Expected Results:  
Same results, but without the excessive CPU usage.  

A workaround is to close and then reopen the Calendar window (or possibly, all
calendar windows) and the excessive CPU utilization goes away.
(Reporter)

Comment 1

16 years ago
This was seen on calendar build 2002103116-cal
(Assignee)

Updated

16 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 2

16 years ago
*** Bug 179705 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

16 years ago
This is fixed in CVS, and in builds available now.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: colint → general
You need to log in before you can comment on or make changes to this bug.