Closed Bug 1795892 Opened 2 years ago Closed 2 years ago

Textbox autocomplete dropdown doesn't shrink to fit the viewport.

Categories

(Firefox :: Theme, defect)

defect

Tracking

()

VERIFIED FIXED
108 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox106 --- unaffected
firefox107 --- unaffected
firefox108 --- verified

People

(Reporter: emilio, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image image.png

See screenshot.

Make sure autocomplete richlistbox contents don't influence the minimum popup
size, just like we did for arrowscrollbox in bug 1793662.

Move common overflow declarations to xul.css, and make remove the
arrowscrollbox rule, since it is now redundant (the arrowscrollbox also matches
::part(content)).

Set release status flags based on info from the regressing bug 1790616

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a01c762bb09c
Fix sizing of richlistbox in popups. r=dao
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 108 Branch
See Also: → 1796088

Sorry didn't get around to testing until now. Is there a separate bug filed for the height attribute? See e.g. the tags selector in the edit bookmark panel. You can paste 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, a, b, c, d, e, f, g, h, i, j, k, l, m, n, o, p, q, r, s, t, u, v, w, x, y, z in the input field to make it really big

height="foo" should be replaced by style='height: foo' (or a CSS equivalent), is that what you meant?

STR:
Open the following
And then double click on input field

data:text/html,<input type="text" name="test" autocomplete="on" list="test"><datalist id="test"><option value="1"><option value="2"><option value="4"><option value="5"><option value="6"><option value="7"><option value="8"><option value="9"><option value="0"><option value="1"><option value="2"><option value="4"><option value="5"><option value="6"><option value="7"><option value="8"><option value="9"><option value="0"><option value="1"><option value="2"><option value="4"><option value="5"><option value="6"><option value="7"><option value="8"><option value="9"><option value="0"><option value="1"><option value="2"><option value="4"><option value="5"><option value="6"><option value="7"><option value="8"><option value="9"><option value="0"><option value="1"><option value="2"><option value="4"><option value="5"><option value="6"><option value="7"><option value="8"><option value="9"><option value="0"><option value="1"><option value="2"><option value="4"><option value="5"><option value="6"><option value="7"><option value="8"><option value="9"><option value="0"><option value="1"><option value="2"><option value="4"><option value="5"><option value="6"><option value="7"><option value="8"><option value="9"><option value="0"></datalist>

I can reproduce the issue in Nightly108.0a1(20221019083142 changeset:b7be85a10f695875d633e02afb600771acdc6a04)

This patch did not totally fix the drop-list issue I referred to yesterday. The list is still way huge, only takes up 1/2 page now :(
at least now its no longer crashing the browser.

Probably need to re-open this bug... ?

See Also: → 1796137
See Also: → 1796138

(In reply to Emilio Cobos Álvarez (:emilio) from comment #6)

height="foo" should be replaced by style='height: foo' (or a CSS equivalent), is that what you meant?

Yeah, looks like that is the only instance except for in tests

QA Whiteboard: [qa-108b-p2]

Reproduced with Fx 108.0a1 (2022-10-19) on Windows 10 based on comment 7.
Verified fixed with Fx 109.0a1 (2022-11-23) on Windows 10, Ubuntu 22.04 and macOS 12.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-108b-p2]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: