Problem with form submission by JavaScript, which is didn't occur in Mozilla 1.0.1, but in 1.1

VERIFIED FIXED

Status

()

VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: ruediger.kubsch, Assigned: alexsavulov)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

In http://www.firstcampus.com/de/index.php a form is submitted to login to the
page. This is simply done by "document.forms[1].submit()". This causes no
JavaScript error, but the submission fails and login is refused.
With Mozilla 1.0.1 this problem did not occur. I think the problem is somewhere
in the form submission. I will add an attachement with the relevant part of the
pages source code.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Login is refused the same way as if I typed a wrong user name.
(Reporter)

Comment 1

16 years ago
Created attachment 105925 [details]
Code fragment from the specified page
(Assignee)

Comment 2

16 years ago
reproter,
i see you're using a pretty old version of mozilla. i would suggest to try wih
one of the nightlies and see if you can login. you can get nightlies at
ftp://ftp.mozilla.org/pub/mozilla/nightly/ . i don't have an account with those
guys so i would appreciate if you could find some time to test. thx!
(Reporter)

Comment 3

16 years ago
Thanks.

This "pretty old version" is the last one marked as stable. 

I tried Mozilla 1.2 and the problem is solved.

Thanks again for the quick help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

16 years ago
yeah, sorry if it sounded sarcastic. for us devs 2 weeks is already old though.
we usually test only with the latest versions since so many fixes are flowing in
all the time. the developers usually pull at least once a week, but most of them
2 or 3 times. glad I could help. alles gute und danke, dass Sie Mozilla
verwenden! ;-)

Comment 5

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.