Selection does not invert on an 8-bit display useably

VERIFIED FIXED in M15

Status

()

P3
major
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: tor, Assigned: pavlov)

Tracking

({helpwanted})

Trunk
Sun
Solaris
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
When apprunner is run on an 8-bit pseudocolor display, the selection
does not reverse video as expected.  Drag selections or double/triple
clicked selections do not appear any different than normal text.  Makes
various editing operation impossible.

Tested on 11/3 evening CVS pull compiled solaris/native .
(Assignee)

Updated

19 years ago
Whiteboard: HELP WANTED
Target Milestone: M15

Updated

19 years ago
Keywords: helpwanted
Whiteboard: HELP WANTED

Comment 1

19 years ago
Is this related to bug 10699?
BTW: I see this under Linux 8-bit displays too (02200022).
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
I hope i just fixed this.  tor, could you verify?
(Assignee)

Comment 3

19 years ago
*** Bug 30531 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
tor, could you possibly verify this on a current build? QA doesn't have any Sun
boxes.
(Reporter)

Comment 5

19 years ago
A linux box running in 8-bit mode will exhibit the same problem/solution.
Nevertheless, I'll try to test on an 8-bit solaris box sometime today.
(Reporter)

Comment 6

19 years ago
Created attachment 6473 [details]
selection on an 8-bit screen
(Reporter)

Comment 7

19 years ago
See the attached image - while the selection area is now visible, the actual
text being selected is unreadable (at least for black on white text).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Selection does not invert on an 8-bit display → Selection does not invert on an 8-bit display useably

Comment 8

19 years ago
Thanks!
(Assignee)

Comment 9

19 years ago
*** Bug 14751 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

19 years ago
selection isn't XORing anymore.  marking this bug fixed.  filing a new bug that
XORd painting doesn't work very well on 8bit displays -- bug 34039.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 11

19 years ago
I'm unable to reproduce this problem on the April 3rd Linux build configured for 
8-bit depth. Thus, verifying as fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.