Exception date messing up a repeated event

VERIFIED DUPLICATE of bug 178473

Status

Calendar
General
VERIFIED DUPLICATE of bug 178473
15 years ago
12 years ago

People

(Reporter: Erich 'Ricky' Iseli, Assigned: Mike Potter)

Tracking

Details

(Reporter)

Description

15 years ago
Assume you want to enter a recurring event. This will happen every Tuesday from
2PM to 4PM, for the next 5 weeks.

Steps to reproduce:
1. Double-click on this week's Tuesday (in the monthly view), (this will bring
up the add event dialog. !! This will also make jump the CPU usage to around
80%, will file another bug on this
2. Give it a title, and modify the start and end time to 2PM and 4PM.
3. Click on the recurence tab
4. Check "repeat every" (and keep the default "1 week")
5. Select the radio button "Until" (instead of "forever") At this stage, you
should see an error message in red below, saying that "Your repeat time ends
before your end time" (note that the OK button is now disabled because of that)
6. Click on the date picker and choose the Tuesday in 5 weeks
7. Note that the error message didn't go away and the OK button is still grayed
out. Will file another bug on this. Workaround: select the radio button
"forever" and then select "until" again. The date you set beforehand was remembered.
8. Click on the date picker in the "exceptions" frame
9. Select the second Tuesday in your list
10. Click the "add exception" button
11.Click OK

Expected result: This tuesday, the tuesday in 2, 3 and 4 weeks should have the
event, but not the tuesday in one week.

Buggy result: The whole first week until the next Monday has the events, then
the Tuesdays in 2, 3, and 4 weeks have it too. So for some reason, the calendar
doesn't understand that the end date of the event is the same day, and for some
reason, this buggy behavior gets interrupted because of the exception, and from
then on, working fine.

Workaround: set the first Wednesday also to be an exception, even if normally
this day would never have the event.
(Reporter)

Updated

15 years ago
Depends on: 179698

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 178473 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
QA Contact: colint → brantgurganus2001
Resolution: --- → DUPLICATE

Comment 2

14 years ago
VERIFIED
Status: RESOLVED → VERIFIED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.