work offline not unchecked when toggled from status bar

VERIFIED FIXED in mozilla1.4alpha

Status

SeaMonkey
UI Design
--
trivial
VERIFIED FIXED
16 years ago
7 years ago

People

(Reporter: John Mertic, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
mozilla1.4alpha
x86
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021105
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021105

When you switch from Work Online to Work Offline and then back to Work Online
using the status bar icon, the check in the file menu next to Work Offline
remains checked

Reproducible: Always

Steps to Reproduce:
From Work Online mode
1. Click on the Work Offline icon in the status bar
2. Click on the same icon ( now used to go back Online )


Actual Results:  
In the File menu, the check next to Work Offline is still there

Expected Results:  
There should be no check next to Work Offline

Comment 1

16 years ago
CONFIRMED 2002111108
Seems that it's pourely cosmetic issue; clicking the Offline item in the menu
redraws teh statusbar icon properly; and statusbar icon sets internal
online/offline flag properly as well. You can make the checkmarka appear in the
menu by clicking the icon, but not disappear.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Depends on: 158976

Comment 2

16 years ago
See bug 158976 for more details. It might happen that the checkmark
functionality will be removed at all...

Comment 3

16 years ago
linux too
OS: Windows 2000 → All

Comment 4

16 years ago
I believe we are going to back out the check/unchecked
for work on/off line and go back to the old way.
Wesha is correct that bug 158976 is the bug that
landed this feature. When module owners respond to that
bug, than i'll make the appropriate changes to this bug
(invalid if we are going to go back to the old way
or assign the bug if we change our minds and we want
this feature).


Comment 5

16 years ago
*** Bug 183908 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

16 years ago
Created attachment 114006 [details] [diff] [review]
Proposed patch

See bug 158976 for an alternative approach.
re-assigning to neil.

neil, I assume you need r/sr for this.
Assignee: asa → neil
Comment on attachment 114006 [details] [diff] [review]
Proposed patch

asking jag to review neils patch (since this is xpfe) and I can sr.
Attachment #114006 - Flags: superreview?(sspitzer)
Attachment #114006 - Flags: review?(jaggernaut)
neil, do you think could sort out all three bugs (this one, bug #80971, and bug
#158976) in 1.4?
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.4alpha

Comment 10

16 years ago
*** Bug 193655 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
*** Bug 195303 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
*** Bug 195617 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
*** Bug 196622 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
UA: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030304

I don't see it mentioned in the comments, but this also happens if you, say, go
offline in mailnews, then go back online in navigator.  The checkmark in the
browser is correct, but the check is still next to 'work offline' in the
mailnews File> dialogue.

Cosmetic, but confusing.

Comment 15

15 years ago
Confirm comments about various behaviours; also, if you're
offline, click "Get Msgs" in Mail and then click "Go Online"
in the dialog that pops up, this too confuses the indicators.

Basically the various methods and indicators for going/being
on- and offline seem to not be synchronised with eachother.

I've put up with this annoyance since <whenever>, but it would
seem a fairly trivial thing to fix for what is supposed to be
the polished and perfected 1.4 Final, before we head off to
Phoenixland.

Comment 16

15 years ago
Lets assign this to a component so it gets QA.
Component: Browser-General → XP Apps: GUI Features
QA Contact: asa → paw
(Assignee)

Updated

15 years ago
Attachment #114006 - Flags: review?(jag) → review?(dean_tessman)

Comment 17

15 years ago
Comment on attachment 114006 [details] [diff] [review]
Proposed patch

Short and sweet.  r=me
Attachment #114006 - Flags: review?(dean_tessman) → review+
(Assignee)

Comment 18

15 years ago
Comment on attachment 114006 [details] [diff] [review]
Proposed patch

sr hokey-cokey ;-)
Attachment #114006 - Flags: superreview?(sspitzer) → superreview?(rbs)

Updated

15 years ago
Attachment #114006 - Flags: superreview?(rbs) → superreview+
(Assignee)

Comment 19

15 years ago
Comment on attachment 114006 [details] [diff] [review]
Proposed patch

Cosmetic improvement for people who work offline, no risk to anyone else.
Attachment #114006 - Flags: approval1.5b?

Comment 20

15 years ago
Comment on attachment 114006 [details] [diff] [review]
Proposed patch

a=asa (on behalf of drivers) for checkin to Mozilla 1.5beta.
Attachment #114006 - Flags: approval1.5b? → approval1.5b+
(Assignee)

Comment 21

15 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
*** Bug 216003 has been marked as a duplicate of this bug. ***

Comment 23

15 years ago
If someone else besides paw can verify it, that would be great.

Comment 24

15 years ago
v.
Status: RESOLVED → VERIFIED
*** Bug 229940 has been marked as a duplicate of this bug. ***

Comment 26

15 years ago
*** Bug 205553 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.