Closed Bug 1797581 Opened 1 month ago Closed 14 days ago

[4.1] Add API support for ignoring sites for cookie banner handling in GV

Categories

(GeckoView :: Core, task, P1)

All
Android

Tracking

(firefox109 fixed)

RESOLVED FIXED
109 Branch
Tracking Status
firefox109 --- fixed

People

(Reporter: amejia, Assigned: amejia)

References

(Blocks 1 open bug)

Details

(Whiteboard: [geckoview:m109])

Attachments

(1 file)

This will allow users to add a site to the exception list for cookie banner handling.

Summary: Add API support for ignoring sites for cookie banner handling → Add API support for ignoring sites for cookie banner handling in GV
Summary: Add API support for ignoring sites for cookie banner handling in GV → [4.1] Add API support for ignoring sites for cookie banner handling in GV
Blocks: 1797605
No longer blocks: 1797577
No longer blocks: 1797578
Assignee: nobody → amejiamarmol
Severity: -- → N/A
Type: enhancement → task
Attachment #9302764 - Attachment description: WIP: Bug 1797581 - Add API support for ignoring sites for cookie banner handling in GV → Bug 1797581 - Add API support for ignoring sites for cookie banner handling in GV
Duplicate of this bug: 1797608
Priority: -- → P1
Whiteboard: [geckoview:m109]
Pushed by amejiamarmol@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bfcfccd2e100
Add API support for ignoring sites for cookie banner handling in GV r=geckoview-reviewers,owlish,calu

Thanks :noemi_erli, I updated the patch to address the failing test, below the try link. I'll try to land again.
https://treeherder.mozilla.org/jobs?repo=try&revision=231ccff9de163105b7ba92e8d2132dd18eae258f

Flags: needinfo?(amejiamarmol)
Pushed by amejiamarmol@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b7fda79c777f
Add API support for ignoring sites for cookie banner handling in GV r=geckoview-reviewers,owlish,calu

🎉!!

Status: NEW → RESOLVED
Closed: 14 days ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch
You need to log in before you can comment on or make changes to this bug.