Random crash when doing LDAP search on Address Book [@ nsLDAPConnection::OnStopLookup()]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: ji, Assigned: dmose)

Tracking

({crash})

Trunk
x86
All
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

16 years ago
build: Linux 11/11 1.0 branch build
OS: Red Hat 7.2.

When I do ldap quick search on Address Book, I have crashes sometimes.

Steps to reproduce:
1. Open Address Book.
2. Connect to a ldap server, highlight the ldap connection on the address book
list. 
3. In quick search field, enter something that doesn't match any entry. Hit
Enter, no matches found. Hit Enter again, crash.
4. Sometimes, it crashes when I turn off Ja IME and hit Enter in quick search
field. Actaully it crashes more often in this case. For example, set cursor in
quick search field, turn on IME by pressing Shift <space>, enter some ja chars
in quick search field, press Shift <space> again to turn off IME. Then hit Enter
key in quick search field, crash.

The crash is not consistent, it happens about 3 out of 10 tries.
And I don't get crash on Windows build.

Below is the call stack: (Incident ID:  13849761/13850060/13850255/  13851335)
 Call Stack:     (Signature = nsLDAPConnection::OnStopLookup() 8b3b90b0)
     nsLDAPConnection::OnStopLookup()  
     XPTC_InvokeByIndex()  
     EventHandler()  
     PL_HandleEvent()  
     PL_ProcessPendingEvents()  
     nsEventQueueImpl::ProcessPendingEvents()  
     event_processor_callback()  
     our_gdk_io_invoke()  
     libglib-1.2.so.0 + 0xff9e (0x40390f9e)  
     libglib-1.2.so.0 + 0x11773 (0x40392773)  
     libglib-1.2.so.0 + 0x11d39 (0x40392d39)  
     libglib-1.2.so.0 + 0x11eec (0x40392eec)  
     libgtk-1.2.so.0 + 0x94333 (0x402ae333)  
     nsAppShell::Run()  
     nsAppShellService::Run()  
     netscape-bin + 0x90b9 (0x080510b9)  
     netscape-bin + 0x98a7 (0x080518a7)  
     libc.so.6 + 0x1c507 (0x404d9507)

Updated

16 years ago
Severity: normal → critical
Keywords: crash

Updated

16 years ago
QA Contact: yulian → gchan

Updated

16 years ago
Summary: Radom crash when doing ldap search on Address Book → Random crash when doing ldap search on Address Book

Comment 1

15 years ago
*** Bug 218844 has been marked as a duplicate of this bug. ***

Updated

15 years ago
OS: Linux → All
Summary: Random crash when doing ldap search on Address Book → Random crash when doing LDAP search on Address Book [@ nsLDAPConnection::OnStopLookup()]

Comment 2

15 years ago
*** Bug 219066 has been marked as a duplicate of this bug. ***
Product: MailNews → Core

Comment 3

13 years ago
Mark
Oleg

WFM?  I can't reproduce, and I've never seen this in 2 years now of using ldap.

Comment 4

13 years ago
no failures after ~30 attempts which included special characters TB version 1.6a1 (20051113)

Comment 5

13 years ago
(messed up)
Assignee: srilatha → dmose

Comment 6

13 years ago
WFM 
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
Crash Signature: [@ nsLDAPConnection::OnStopLookup()]
You need to log in before you can comment on or make changes to this bug.