Closed Bug 1798140 Opened 1 month ago Closed 24 days ago

Columns can be resized to overlap.

Categories

(DevTools :: Storage Inspector, defect, P2)

Firefox 107
defect

Tracking

(firefox-esr102 unaffected, firefox106 unaffected, firefox107 wontfix, firefox108 verified)

VERIFIED FIXED
108 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox106 --- unaffected
firefox107 --- wontfix
firefox108 --- verified

People

(Reporter: 6k64x4ma, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot.webp

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:107.0) Gecko/20100101 Firefox/107.0

Steps to reproduce:

  1. Open the Storage Inspector.
  2. Resize columns in the table widget.

Actual results:

Columns can be resized to overlap.

Expected results:

It shouldn't be possible.

Regressed by: 1792473
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

:emilio, since you are the author of the regressor, bug 1792473, could you take a look? Also, could you set the severity field?

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

It was needed only for sticky to work on XUL and it's not needed anymore.

The way splitters work on modern flexbox is that they take the min-width
property of the element they're resizing (without looking at descendants).

This is done for performance reasons (flex item min-width is more expensive to
compute on isolation than XUL flex was). Removing the wrapper makes the
min-width be on the right element anyways.

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Flags: needinfo?(emilio)
Severity: -- → S3
Priority: -- → P2
See Also: → 1258285
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c78b0be860b1
Remove table-widget-wrapper. r=jdescottes
Pushed by ctuns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1772e0cda827
Fix lint failure r=fix CLOSED TREE
Status: ASSIGNED → RESOLVED
Closed: 24 days ago
Resolution: --- → FIXED
Target Milestone: --- → 108 Branch
Flags: qe-verify+

Reproduced the issue on Nightly 108.0a1 build from 2022-10-29.
Verified it on Beta 108.0b5 build on MacOS 12 ARM, Windows 10 and Ubuntu 22.04, and can confirm that the issue is fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.