Cannot quickly delete multiple messages without showing any of them

RESOLVED EXPIRED

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED EXPIRED
16 years ago
8 years ago

People

(Reporter: Vincent Jaubert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021111
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021111

Often, mails sent by spammers contain evil features like remotes pictures on the
spammer site that are triggered every time you look at the mail, with special
formated links that report to the spammer that you have read the mail (and so
that your email is valid).
There should be a way to select a message (to delete it, or do other things with
it), without showing it.
Some ideas:
- add a special column for selection (some cases ?). The problem is that new
users could be disturbed by such a feature ("what ! I clicked on my mail but it
didn't showed !")
- make it work with a special keyboard sequence like "press alt + arrows to move
the highlight without showing the emails, and press spacebar to select the message"


Reproducible: Always

Steps to Reproduce:
1.Not applicable
2.
3.

Comment 1

16 years ago
Hi,
Please do not place ideas on the on the mozilla suorce on the 
bugzilla.mozilla.org pages this is a place for bugs and bugs only.
And that might be possible we will have to redo the mail/news source to make
that happen. I might work on that.
1)  Right click on the mail
2)  Select "delete" from the context menu

In what way is this not satisfactory?  ;)
or 
Edit\preferences\Privacy...\Images\[x]Do not load remote images in mail and news
or 
View\Message Body as\Plain Text and after that delete the message.

since there is also Boris way -> invalid (since you can already do it)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

16 years ago
About comment 2 from boris: this is not satisfactory: yes you can select a mail
and delete it with right click. But let's say you have 10 mails you want to
delete: how do you do that ? You must delete each mail with the right click
method. This is pretty long. You can say that it's possible to shift+click to
select the ten mail in the same sequence, but for that you have to select (and
show!) at least one mail for the beginnig of your selection.

About comment 3 from Matti: with the first method you can not see anymore
remotes images from all your mail! That is not satisfactory: there are mails
from online vendors that are not spam (i have sollicited them) and that i want
to be able to read.
With the second method, it's the same problem as with boris's method: it will
take you many time to delete your ten mails (or more, i get something like 30
spams a day).

About comment 1 from Bryan: i am not sure to understand what you are talking
about (englisch is not my native language). Are you saying that enhancement
suggetions are not welcome on bugzilla anymore ?
Vincent, please ignore comment 1.  It has nothing to do with reality.  Thank you
for answering the "how is this not satisfactory" part.  ;)

Reopening, setting summary to desribe the real problem.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Add a select a mail without showing feature → Cannot quickly delete multiple messages without showing any of them
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
QA Contact: olgam → laurel

Comment 6

16 years ago
This should probably be changed to an RFE.

I believe that this is a valuable idea. I am having problems with certain emails
always crashing Mozilla (I have already entered a bug on this) and after the
first time the message crashed me it sure would have been nice to delete it
without having to "open" it.  Thanks.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
QA Contact: laurel → message-display

Comment 7

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 8

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 9

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 10

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago8 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.