[DOGFOOD][REGRESSION] Account Setup dialog doesn't come up.

VERIFIED FIXED in M11

Status

SeaMonkey
MailNews: Account Configuration
P3
critical
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: scottputterman, Assigned: scottputterman)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
In this morning's build, the account setup dialog doesn't come up.  A blank
window appears and everything just hangs.
(Assignee)

Comment 1

19 years ago
In case someone not in mailnews looks at this, open mailnews, go to the Edit
menu and choose Account Setup to see this.
(Assignee)

Comment 2

19 years ago
When I break into the debugger I end up here most of the time

USER32! 77e71ca1()
nsWindow::OnResize(nsRect & {x=0 y=0 width=355 height=329}) line 3319
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1226272, long *
0x0012b5b0) line 2758 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x00070c3a, unsigned int 71, unsigned int 0, long
1226272) line 581 + 27 bytes
USER32! 77e719d0()
USER32! 77e730a3()
NTDLL! 77f763a3()
nsWebShell::SetBounds(nsWebShell * const 0x0304fc00, int 0, int 0, int 355, int
329) line 1219
nsHTMLFrameInnerFrame::Reflow(nsHTMLFrameInnerFrame * const 0x0304dcf0,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0) line 907
nsContainerFrame::ReflowChild(nsIFrame * 0x0304dcf0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 386 + 31 bytes
nsHTMLFrameOuterFrame::Reflow(nsHTMLFrameOuterFrame * const 0x03027560,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0) line 358
nsBoxFrame::FlowChildAt(nsIFrame * 0x03027560, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {"initial"}) line 1069
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {x=0 y=0 width=5331
height=4938}) line 643
nsBoxFrame::Reflow(nsBoxFrame * const 0x02539790, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 505
nsBoxFrame::FlowChildAt(nsIFrame * 0x02539790, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 1, nsString & {"initial"}) line 1069
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {x=0 y=0 width=5331
height=4938}) line 643
nsBoxFrame::Reflow(nsBoxFrame * const 0x02528498, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 505
nsBoxFrame::FlowChildAt(nsIFrame * 0x02528498, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {"initial"}) line 1069
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {x=0 y=0 width=5331
height=4938}) line 643
nsBoxFrame::Reflow(nsBoxFrame * const 0x02526980, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 505
nsBoxFrame::FlowChildAt(nsIFrame * 0x02526980, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {"initial"}) line 1069
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {x=0 y=0 width=5331
height=4938}) line 643
nsBoxFrame::Reflow(nsBoxFrame * const 0x02524e68, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 505
nsBoxFrame::FlowChildAt(nsIFrame * 0x02524e68, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 1, nsString & {"initial"}) line 1069
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {x=150 y=150
width=8608 height=4938}) line 643
nsBoxFrame::Reflow(nsBoxFrame * const 0x0251fd20, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 505
nsBoxFrame::FlowChildAt(nsIFrame * 0x0251fd20, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {"initial"}) line 1069
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {x=0 y=0 width=8910
height=5923}) line 643
nsBoxFrame::Reflow(nsBoxFrame * const 0x0251e208, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 505
nsContainerFrame::ReflowChild(nsIFrame * 0x0251e208, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 386 + 31 bytes
RootFrame::Reflow(RootFrame * const 0x03018250, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 328
nsContainerFrame::ReflowChild(nsIFrame * 0x03018250, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 386 + 31 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x03018580, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 510
nsHTMLReflowCommand::Dispatch(nsHTMLReflowCommand * const 0x0394b710,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsSize & {width=8910
height=5925}, nsIRenderingContext & {...}) line 136
PresShell::ProcessReflowCommands(PresShell * const 0x02fe4dd0) line 1456
PresShell::ExitReflowLock(PresShell * const 0x02fe4dd0) line 675
nsFrameImageLoader::NotifyFrames(int 1) line 506
nsFrameImageLoader::Notify(nsIImageRequest * 0x03955b40, nsIImage * 0x00000000,
nsImageNotification nsImageNotification_kDimensions, int 11, int 11, void *
0x00000000) line 399
ns_observer_proc(void * 0x03950cb0, long 2, void * 0x0012dbc4, void *
0x03955b40) line 76
XP_NotifyObservers(OpaqueObserverList * 0x03950d40, long 2, void * 0x0012dbc4)
line 255 + 28 bytes
il_dimensions_notify(il_container_struct * 0x03954490, int 11, int 11) line 235
+ 18 bytes
ImgDCallbk::ImgDCBHaveHdr(ImgDCallbk * const 0x03954290, int 11, int 11) line 86
+ 20 bytes
il_size(il_container_struct * 0x03954490) line 748
ImgDCallbk::ImgDCBImageSize(ImgDCallbk * const 0x03954290) line 150 + 12 bytes
il_gif_write(il_container_struct * 0x03954490, const unsigned char * 0x02566100,
long 64) line 1324 + 18 bytes
GIFDecoder::ImgDWrite(GIFDecoder * const 0x0394bae0, const unsigned char *
0x02566100, long 64) line 72 + 20 bytes
IL_StreamWrite(il_container_struct * 0x03954490, const unsigned char *
0x02566100, long 64) line 971 + 26 bytes
NetReaderImpl::Write(NetReaderImpl * const 0x039524d0, const unsigned char *
0x02566100, long 64) line 98 + 20 bytes
ImageConsumer::OnDataAvailable(ImageConsumer * const 0x039523d0, nsIChannel *
0x03932c60, nsISupports * 0x00000000, nsIInputStream * 0x039174d8, unsigned int
0, unsigned int 64) line 273 + 23 bytes
nsChannelListener::OnDataAvailable(nsChannelListener * const 0x03907be0,
nsIChannel * 0x03932c60, nsISupports * 0x00000000, nsIInputStream * 0x039174d8,
unsigned int 0, unsigned int 64) line 1402
nsFileChannel::OnDataAvailable(nsFileChannel * const 0x03932c64, nsIChannel *
0x038d23c0, nsISupports * 0x00000000, nsIInputStream * 0x039174d8, unsigned int
0, unsigned int 64) line 444
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x0394b800)
line 413
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x03948bd0) line 169 + 12 bytes
PL_HandleEvent(PLEvent * 0x03948bd0) line 537 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x02f8f1a0) line 498 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00350c68, unsigned int 49408, unsigned int 0,
long 49869216) line 972 + 9 bytes
USER32! 77e71820()
02f8f1a0()

Updated

19 years ago
Severity: normal → blocker
Summary: Account Setup dialog doesn't come up. → [DOGFOOD][REGRESSION] Account Setup dialog doesn't come up.

Updated

19 years ago
Severity: blocker → critical

Comment 3

19 years ago
More info that Scott posted to builds newsgroup:  "When a folder is selected
before bringing up the account setup dialog, it works.  When there's no
selection, then the dialog hangs."
(Assignee)

Comment 4

19 years ago
So this seems to be what is happening.

When you have a folder selected in the folder pane and bring up the account
setup dialog, everything works.

When you have nothing selected in the folder pane and bring up the account
wizard, it works if you have accounts that don't take up the entire tree in the
dialog.  However if the accounts overflow the area, then this occurs.  The
open="true" seems to be contributing to it.  I wonder if I had 20 accounts and
no open="true" if this would also happen.

Anyway, I recommend we take out open="true" until we solve this, otherwise
people with a bunch of accounts (I could make this happen with 5 accounts) will
run into this problem without realizing what is happening.

Unless we think having 5 accounts is abnormal and would rather have the accounts
appear open.
(Assignee)

Comment 5

19 years ago
OK, thanks to waterson for the fix.  divs around trees need to be constrained.
by adding width:100px;height:100px to the style rule, this worked again.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
I just checked in the fix.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Assignee: alecf → putterman
Status: REOPENED → NEW

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago

Comment 7

19 years ago
Assigning back to you so you get credited for this fix!

Updated

19 years ago
QA Contact: lchiang → nbaca
Target Milestone: M11

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
Build 1999110808M11: Win32/NT4
Verified Fixed. I had 4 mail accounts, a local account and a news account. With
no folder selected I could see the Account Settings dialog by selecting
Edit/Account Settings. I also noticed that the accounts overflowed which created
a scrollbar and I could still view the Account Settings dialog without a
problem.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.