backspace works too easily across multiple addresses

VERIFIED DUPLICATE of bug 170292

Status

MailNews Core
Composition
VERIFIED DUPLICATE of bug 170292
16 years ago
10 years ago

People

(Reporter: James Scott, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2) Gecko/20021112
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2) Gecko/20021112

When adding addresses to a composed mail, its very easy to delete addresses that
have already been added.  This is because the backspace key works across
multiple addresses, a feature which is non-intuitive (one woudld normally expect
to "hit" the left hand side of the box you were currently in, and stop deleting
text).

The feature of backspacing across addresses is a useful one, but perhaps some
changes should be made to make it less "hungry" to delete other addresses.  For
example, I suggest the two changes:
- _holding down_ backspace only goes to the left hand side of the current box,
- you are required to hit and release backspace twice in succession instead of
once, to cause a move between an empty address and the address above.  

This would not greatly affect the time taken to delete loads of addresses, it
means it takes three hits of "backspace" instead of two, per address. However,
it would potentially greatly cut down on accidental deletions.

This problem is made worse by the fact that if you use a reply-to address, and
press "backspace" a few too many on the _first_ address, your reply-to address
gets edited/deleted by accident, AND when you finally retype your reply-to and
hit enter, the next address also comes up as a reply-to!  Then you have to start
using the mouse to fix things up, which takes ages compared to typing.

Basically, the feature of backspacing across multiple addresses is violating the
principle that anything simple (i.e. not a <ctrl> or <alt> sequence) that you do
with the keyboard in X presses should be un-doable in X presses.

Reproducible: Always

Steps to Reproduce:
1. compose a mail, create a to: address in it
2. add a new to: address, but decide against it and delete the name
3. "accidentally" hit backspace a few too many times, or hold it down for too long

Actual Results:  
All the addresses (including the reply-to!) get deleted

Expected Results:  
I only wanted to edit the address I was on

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 170292 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.