Closed Bug 1799055 Opened 1 year ago Closed 1 year ago

108.a01 (3.nov) won't work with oracle oauth2 via outlook.office365.com serever because asks for something "new" (107 works ok)

Categories

(Thunderbird :: Untriaged, defect)

Thunderbird 108
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: arhi.smece, Unassigned)

References

(Regression)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:106.0) Gecko/20100101 Firefox/106.0

Steps to reproduce:

install thunderbird 108.a01 on brand new account (windows11 and macos 13.0 m1) and try to setup oracle email account (107 works normally, upgrade to 108 fails, brand new on brand new account, on brand new computer same behavior)

imap / outlook.office365.com:993 / SSL/TLS / oauth2

Actual results:

upon clicking on "done" oauth2 win opens, user/pass go through, 2fa go through and then the system complains that app is "unauthorized" as it asks for following data:

This app requires your admin's approval to:

  • Read and write access to mailboxes via IMAP.
  • Read and write access to mailboxes via POP.
  • Send emails from mailboxes using SMTP AUTH.
  • Maintain access to data you have given it access to
  • View users' basic profile

Expected results:

This window complaining that admin approval is needed should not show and the imap should be connected to and emails downloaded (as it does on 107 or earlier)

Would be very interesting which one of these 5 items is new and how to "disable" it for a specific account

We're changing the OAuth2 app id (bug 1685414) and this is one unfortunate side affect.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Keywords: regression
Regressed by: 1685414
Resolution: --- → INVALID

(In reply to Magnus Melin [:mkmelin] from comment #1)

Thanks for confirmation and explanation!

You need to log in before you can comment on or make changes to this bug.