With DOM regenerated <A HREF> does not open window

RESOLVED DUPLICATE of bug 169429

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 169429
15 years ago
15 years ago

People

(Reporter: Saulius Gurklys, Assigned: jst)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021112
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021112

Sorry for subject, do not know how to make it short and clear.
Let me explain the whole situation. There are two pages 
http://www.vtex.lt/sagu/mozilla/f.html -- "Father"
http://www.vtex.lt/sagu/mozilla/c.html -- "Child"
On the "father" page there is a table with a body with two cells in one row.
In the first cell there is <A HREF> "C" with event "ONCLICK". When this URL
is clicked javascipt function "new_child_window()" is called, which opens
a "child" window with http://www.vtex.lt/sagu/mozilla/c.html content.
When "Close" is clicked in "child" window other javascipt function is called
wich with DOM functions regenerates table body on "fathers" page and close
the child window.
Problem is that when table on "father" page is regenerated, URL is regenerated
too. But now clicking the URL no window is opened.


Reproducible: Always

Steps to Reproduce:
1.Goto http://www.vtex.lt/sagu/mozilla/f.html
2.Click "C" in the table (child window opens with two alerts - one before
  window.open other after)
3.Click "Close" in "child" window (table on teh "father" page is regenerated,
   child window is closed)
4.Click on "C" (alert before "window.open" shows, but after that nothing happens)

Actual Results:  
Window is not open when clicking the regenerated URL.

Expected Results:  
It should open child window and when table body is regenerated)
Looks like we're not even calling that event handler...
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 169429 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.