Closed Bug 1799690 Opened 3 months ago Closed 3 months ago

`./mach clang-format` fails: bootstrap gives 15.0.4 but mach requires 15.0.3

Categories

(Developer Infrastructure :: Lint and Formatting, defect)

x86_64
Windows 11
defect

Tracking

(firefox-esr102 unaffected, firefox106 unaffected, firefox107 unaffected, firefox108 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr102 --- unaffected
firefox106 --- unaffected
firefox107 --- unaffected
firefox108 --- fixed

People

(Reporter: saschanaz, Assigned: glandium)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

> ./mach clang-format --outgoing
 0:04.76 Setting up artifact clang-tidy.tar.zst
 0:04.76 Using artifact from local cache: C:\Users\sasch\.mozbuild\toolchains\a7b8f5adc1919369-clang-tidy.tar.zst
 0:04.82 untarring "C:\Users\sasch\.mozbuild\clang-tools\clang-tidy.tar.zst"
 0:06.91 ERROR: You're using an old or incorrect version (clang-format version 15.0.4 (taskcluster-fdElb-6jR76Wxcy-XUBKzg)) of clang-format binary. Please update to a more recent one (at least > 15.0.3) by running: './mach bootstrap'

https://searchfox.org/mozilla-central/rev/b6d0ad6ba24b3d075e357e52160cd8fc7f911ba9/tools/clang-tidy/config.yaml#22 still points to 15.0.3.

https://searchfox.org/mozilla-central/rev/b6d0ad6ba24b3d075e357e52160cd8fc7f911ba9/python/mozbuild/mozbuild/code_analysis/mach_commands.py#523-525 explicitly requires the pinned version although the error message implies newer versions are allowed.

Not sure it's a regression, but let's see:

Regressed by: clang-15

Set release status flags based on info from the regressing bug 1784202

:glandium, since you are the author of the regressor, bug 1784202, could you take a look? Also, could you set the severity field?

For more information, please visit auto_nag documentation.

Flags: needinfo?(mh+mozilla)
Keywords: regression
Flags: needinfo?(mh+mozilla)
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED

This bug has the keyword regression, so its type should be defect.

Type: task → defect
Regressed by: 1799062
No longer regressed by: clang-15
Duplicate of this bug: 1799733
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bd8ff70b6fd4
Update clang-tidy version after clang update. r=firefox-build-system-reviewers,andi
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.