Closed Bug 18000 Opened 20 years ago Closed 20 years ago

Timestamp off by 12 hours when AS decoding

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: samir_bugzilla, Assigned: samir_bugzilla)

Details

The ASEncoder stores time info incorrectly in AppleSingle encoded files. This
causes the Mac Install Wizard to install files with potentially future
timestamps, e.g. "Today, 8:31 PM" when the installation takes place at 11:15 AM.
Target Milestone: M12
Status: NEW → ASSIGNED
Component: JAR Installation → XPInstall
Summary: Timestamp off by 12 hours when AS encoding → Timestamp off by 12 hours when AS decoding
This is not a bug in the encoder: it's a bug in the decoder. The decoder was
lifted from the Nova codebase. Therefore, this bug probably exists in Nova and
subsequent 4.5+ releases. The decoder is reused in 3 separate products:
XPInstall in Mozilla, Mac Install Wizard (during extraction of the xpi engine),
and ASEncoder. Fix in hand will go in when the tree reopens for M12 development.
Changed summary to reflect the problem is during decoding, not during encoding.
QA Contact: gbush → jimmylee
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Fix checked in yesterday: should be in today's build. AppleSingle a file
with a resource fork using Fetch. On a Unix system, zip it up with an install.js
that installs it. Install using XPInstall in Mozilla. The time stamp should be
the same as the original file on the Mac. Using an old build this was not true:
file creation and modification times were off by 12 hours.
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Status: RESOLVED → VERIFIED
Build 1999-12-17-10-M12(MAC)

We decode files right!   http://jimbob/jars/f_18000_mac.xpi
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.