does not allow form submission

VERIFIED WORKSFORME

Status

Tech Evangelism Graveyard
English US
VERIFIED WORKSFORME
15 years ago
3 years ago

People

(Reporter: Garrett Smith, Assigned: Arun Ranganathan)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826

Does not properly process form submission. Additionally, there are display
problems with this page.

Reproducible: Always

Steps to Reproduce:
1. select All Areas within zip code
2. type a keyword "dhtml"
3. select Statewide search 
4. Select california
5. click search
Actual Results:  
form is processed. http response includes same html form with the message:

"please enter a zip code"

Expected Results:  
The form should be processed.

I cannot determine if the problem is from poor application/use case design or if
there is a compatibility problem with mozilla.

I know only that their site has problems.

Comment 1

15 years ago
The search is doing what it's supposed to do, by design.

You chose the option "Search all job categories within IP CODE", but then you're
trying to specify a STATEWIDE search.  So it errors you out to correct your
input.  Running it in IE6/PC gets the same result.

It could be better designed for the user, but it functions as they intend.
Resolving WFM.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED

Comment 3

15 years ago
tech evang june 2003 reorg
Component: US Ecommerce → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.