running junk mail controls manually should respect preferences-Move to Junk folder

VERIFIED FIXED in mozilla1.4final

Status

VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: sspitzer, Assigned: sspitzer)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.4final

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment, 4 obsolete attachments)

from granrose:

"I run "Run Junk Controls on selected messages" that it marks spams as junk, but
it doesn't move them to my junk folder even though I have that pref set."

Comment 1

16 years ago
I wasn't aware that junkmail.js had included the lines for MOVING to be allowed
yet ... But, I fully agree that "running junk mail controls" should apply ALL
settings (Move, Priority Change, or whatever other features are incorporated
into the Junk Mail UI)

Updated

16 years ago
OS: Windows 2000 → All
Hardware: PC → All
Summary: move messages when running junk mail controls manually → running junk mail controls manually should respect preferences

Updated

16 years ago
Keywords: nsbeta1
*** Bug 188950 has been marked as a duplicate of this bug. ***
taking
Assignee: dmose → sspitzer

Comment 4

16 years ago
>I fully agree that "running junk mail controls" should apply ALL settings 

I agree as well.

Updated

16 years ago
Keywords: nsbeta1+

Updated

16 years ago
Keywords: nsbeta1

Comment 5

16 years ago
Mail triage team: nsbeta1+/adt2
Whiteboard: [adt2]

Comment 6

16 years ago
related/equal to bug 194273?
I'm not so sure about this anymore.

think about whitelisting and local folders (which don't have jmc controls).

Status: NEW → ASSIGNED
QA Contact: laurel → nbaca

Comment 8

16 years ago
If users specifically ask for JMCs to be run, I think they expect it to obey
their settings. 

For Local (non acct) folders, we can either disable the menu item or identify
only (since there is no pref to auto move them).

If a Sender is in a user's AB, we still need to follow the settings the user has
setup. If  the user has "Msgs from people in my AB are not junk" enabled, we
need to obey that. This shouldn't be any different than auto analyzing msgs on
incoming mail.

Comment 9

16 years ago
right.  you have to assume that if someone is running the JMC manually that they
want to do that.  For Local Folders people can do the manual JMC and move the
marked messages by hand if they have to, or we just disable it since only msgs
that people want to save get put into the Local Folders (right?).
see also bug #191042, which needs to be fix for manual running of jmc to be
usable on imap.
Target Milestone: --- → mozilla1.4alpha

Comment 11

16 years ago
I to test with a current build to see which preferences are being respected and
which are not when running JMC on IMAP or POP Folders. 
I think it' already respecting the Address book preference, still checking all
scenarios.
It's not automatically moving the message after analyzing.
Regarding Comment 8 paragraph 2, I just logged a bug 204517, for purge (which is
one of the preferences) to work on a designated Junk in Local Folders so we need
to be careful not to disable functionality for that. 

Comment 12

16 years ago
Running junk mail controls does not respect the Address Book whitelist. 
splitting that out to a new bug so it can be fixed first. bug 204679

Comment 13

16 years ago
updated this bug to be specific to moving to junk folder after manually marking
messages as junk or after running JMC on folder.   
Summary: running junk mail controls manually should respect preferences → running junk mail controls manually should respect preferences-Move to Junk folder
aiming for 1.4 final
Target Milestone: mozilla1.4alpha → mozilla1.4final
Created attachment 123852 [details] [diff] [review]
patch

re-use the existing code for this, in nsMsgDBView.cpp

testing now, to see if it has a problem with moving / deleting messages that
aren't selected.
hmm, this isn't the right approach.

that will heed the "move / delete" on manual code.

I think this has to work differently.

re-working....
Attachment #123852 - Attachment is obsolete: true
Created attachment 123855 [details] [diff] [review]
updated patch
Attachment #123853 - Attachment is obsolete: true
Created attachment 123856 [details] [diff] [review]
new patch
Attachment #123855 - Attachment is obsolete: true
Comment on attachment 123856 [details] [diff] [review]
new patch

seeking review from david.

it's similar in spirit to the fix for bug #194273, except that at the end, we
select and move.

and we only care about the "move on spam" pref, not the "move when manually
marking as spam".

(and there is no delete option.)
Attachment #123856 - Flags: review?(bienvenu)

Comment 21

16 years ago
Comment on attachment 123856 [details] [diff] [review]
new patch

nit - combine these into one || if clause:

+  if (!spamSettings.level)
+    return;   
+  // if the move functionality is turned off, bail out.
+  if (!spamSettings.moveOnSpam)
+    return;
Attachment #123856 - Flags: review?(bienvenu) → review+
Created attachment 123881 [details] [diff] [review]
patch, with david's nit fixed
Attachment #123856 - Attachment is obsolete: true
Comment on attachment 123881 [details] [diff] [review]
patch, with david's nit fixed

this has r/sr=bienvenu

I'll check with asa for a=.
Attachment #123881 - Flags: superreview+
Attachment #123881 - Flags: review+
Attachment #123881 - Flags: approval1.4?
Comment on attachment 123881 [details] [diff] [review]
patch, with david's nit fixed

a=sspitzer,asa (asa over aim earlier today)
Attachment #123881 - Flags: approval1.4? → approval1.4+
fixed for 1.4 final.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 26

16 years ago
Comment on attachment 123881 [details] [diff] [review]
patch, with david's nit fixed

a=asa (on behalf of drivers) for checkin to 1.4.

Updated

16 years ago
QA Contact: nbaca → esther

Comment 27

16 years ago
Using trunk build 20030523 on winxp, linux and macosx this is fixed. verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.