Submit button contains extra spaces on the sides

RESOLVED INVALID

Status

()

Core
Layout: Form Controls
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: daisuke, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021113

I don't know exactly when the change happened, but when I installed
2002111308 on top of a build from last week, the way a submit button
is displayed has changed.

Namely, now they appear to be padded with extra spaces on both sides.

It looks real bad on pages that has button with one character in it
(some japanese pages, for example), because the proportions changed.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
Created attachment 106179 [details]
simple form with two buttons, one japanese, one ascii

this test case displays as intended on IE6, but not in mozilla
This was done on purpose; previously we were cutting off text on buttons with
only one or two characters on them.

As a note, every single browser except IE/Windows has a similar behavior.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

15 years ago
What's the reasoning for padding?
It seems counter intuitive that you would add spaces that you
can't remove. I could understand if instead of cutting buttons
with one or two characters you cut from *all* buttons, but
by padding, we can no longer control that part of the appearance.

BTW, netscape also worked as expected (for me) -- why change things now??
The reasoning is manifold:

1)  It just looks better in the vast majority of cases for the button itself
2)  It's more usable (eg <input type="submit" value="l"> is actually clickable
    instead of being a thin sliver)

You can remove the padding with the "padding" css property (for now), so it's
not "spaces that you can't remove."  As a warning, that may well change
depending on other requirements (like needing the focus outline to hug the
outside of the button instead of the text).
(Reporter)

Comment 5

15 years ago
k, as long as I can work around it somehow, no harm done.
thanks for the info!
You need to log in before you can comment on or make changes to this bug.