Many buttons and images missing in certain web pages and forms

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Vicki Brown, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016

When I log into certain web sites, or access forms on some sites, e.g. to place
an order at an online store, I have noticed that buttons and images are often
missing. I do not experience this problem with IE.

Two sites where I have had this problem are http://www.drugstore.com (try
creating an account there) and http://www.landsend.com (try buying something).

At http://www.cfcl.com/~vlb/Misc/Mozilla/20021113 I have posted two JPEG screen
shots illustrating the problem for drugstore.com. he file
drugstore.com_mozilla.jpg shows the page I see using mozilla; the file
drugstore.com_IE.jpg shows the same page using IE. Note that much of the page
appears blank as viewed with Mozilla.

When I had this problem previously, using landsend.com, I saved the source and
tried to check to see if there was antyhing wrong with it. But when I opened the
saved file locally under Mozilla it worked perfectly. So, I have no idea why the
problem exists but this is the 3rd or 4th site where I've seen it and it is
frustratng to have to switch back to IE.



Reproducible: Sometimes

Steps to Reproduce:
1. Shop on the net
2. Every sxo often you will notice that a page has no buttons and no way to
select things.
3.



Expected Results:  
Buttons and widgets wshould show up and work.

Comment 1

16 years ago
WorksForMe using FizzillaCFM/2002110808 on 10.1.5, but see also bug 179874.
(Reporter)

Comment 2

15 years ago
Still fails in 1.3a; try www.bn.com.

I really wish someone would confirm this and get working on it. Not being able
to access popular sites is a showstopper.

(Aside to Greg K - you're still using 10.1.5?!?  I'm on 10.2.3)

Comment 3

15 years ago
Vicki, can you reproduce this problem using another Mozilla user profile? Does
it still happen using 1.3b?

Comment 4

15 years ago
I can confirm this bug. I have a small website with a paypal button on it. The
paypal button does not show up in Mozilla 1.3b nightly (latest as of this morning)
nor does it show up in Camino 0.7 (also downloaded this morning). This is
happening under OS X (also latest patches).

If you look at http://www.helpmyhusband.com/ you should see a PayPal button on
the main page under the underlined text "Click The Button To Donate Instantly
Through PayPal!". I have done a quick check of the HTML code and don't see any
obvious problems. I also tried the site with Safari and IE for OS X. Neither 
had a problem displaying the PayPal button.

www.drugstore.com is also missing images for me, but Land' End looks fine.

Comment 5

15 years ago
The problem on my page seems to stem from either forms or https inside an http
page or both. Here is the code from my site, http://www.helpmyhusband.com/

<u>Click The Button To Donate Instantly Through PayPal!</u><br>
<form action="https://www.paypal.com/cgi-bin/webscr" method="post">

<input type="hidden" name="cmd" value="_xclick">
<input type="hidden" name="business" value="hmhusband@aol.com">
<input type="hidden" name="no_note" value="1">
<input type="hidden" name="no_shipping" value="1">
<input type="hidden" name="currency_code" value="USD">
<input type="hidden" name="tax" value="0">
<input type="image" src="https://www.paypal.com/images/x-click-but04.gif"
border="0" name="submit" alt="Make payments with PayPal - it''s fast, free and
secure!">
</form>

NOTE: The button that doesn't show up is called in the line:
<input type="image" src="https://www.paypal.com/images/x-click-but04.gif"

This is a call to an HTTPS image at another site from an HTTP page on my site.
I am thinking the mixed security could be the cause of the problem. Either
that or mixed security inside forms. If I change the page to replace the
form with a link, it looks like this:

<a
HREF="https://www.paypal.com/cgi-bin/webscr?cmd=_xclick&business=hmhusband@aol.com&no_note=1&currency_code=USD&tax=0&submit"
target="_blank">Click Here to Donate Through 

<img SRC="https://www.paypal.com/images/x-click-but04.gif" BORDER="0" VSPACE="0"
ALT="Amazon.com logo">PayPal
</a><br><br>

This code also works when I click through, but the image still doesn't show up. 
This sort of reinforces the thought that it might have something to do with
mixed security.

My solution is to copy the image of the button to my site. Once I do that
the button image is no longer HTTPS, but HTTP from my site and it gets displayed
nicely. I also added target="_blank" to the link code. This solves a security
issue with some browsers where paypal didn't work because the browser was still
displaying the frame from my site. This causes the page to break out of the 
frames design of my site when someone clicks through to PayPal. This is
apparently a big issue with IE6.

The code will look like this in a few hours and fixes my problems, but it is
a work around for the problem in Moz.

<a
HREF="https://www.paypal.com/cgi-bin/webscr?cmd=_xclick&business=hmhusband@aol.com&no_note=1&currency_code=USD&tax=0&submit"
target="_blank">Click Here to Donate Through 

<img SRC="paypal_logo.gif" BORDER="0" VSPACE="0" ALT="Amazon.com logo">PayPal
</a><br><br>

Comment 6

15 years ago
Is this problem affected by the HTTP Pipelining setting?

Comment 7

15 years ago
I am not running HTTP Pipelining.

I do think I found the problem. DOH!

I have selected "Accept Images that come from the originating server only" in
Preferences -> Privacy & Security -> Images.

Once I set it to "show all images" the problem went away on most sites.

Maybe Mozilla should change the behavior of the right click menu to say
something like "show image from this server now" instead of "block images from
this server" when you right click on an image that you can't see because it is
from a non-originating server.

Comment 8

15 years ago
Resolving WFM per comment 7. (Paul, you may elect to file that suggestion as a
new bug.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.