Closed Bug 180094 Opened 19 years ago Closed 17 years ago

filtering from pop3 to imap accounts causes messages to be lost, msf corruption

Categories

(MailNews Core :: Filters, defect)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 210614

People

(Reporter: stefan, Assigned: naving)

Details

(Keywords: dataloss)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016


I have two profiles, my home account (pop3) and a work account (imap). because
colleagues often send me work mail to my home account, I created a filter that
moves all mail sent from the work domain to the home account into the inbox of
the  work account. 

what happens: 

mail is not moved. worse, my pop3 inbox is corrupted so that message bodies no
longer match the subject pane information (some messages are the headers of
different messages). if I quit and delete the .msf, the messages that should
have been moved are lost.






Reproducible: Always

Steps to Reproduce:
1.
2.
3.
adding dataloss keyword. 
Keywords: dataloss

just to add, 

even after deleting the msf, and disabling the filter, my inbox remains corrupted. 

Originally reported under bug 66391, but last comments in there indicate no data
loss. Will test again, comment here.
I just tried filters from pop account to inbox (also tried other folders) on
IMAP account.  Mail, of course, is not moved, but is fully intact in the pop3
inbox.  I see no mismatch of header to body when reading any of the messages in
the pop inbox. 

 
By the way, I tried with a recent trunk build, win2000.
 ok. I've attached a screenshot. I reactivated the filter, dowloaded mail, and
as you can see from the attached screenshot, message headers and bodies don't match.

any more diagnostic stuff that would be useful
I can confirm this problem with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.2.1) Gecko/20021130

That is Win2k SP3 and Mozilla 1.2.1

It also happened on previous Mozilla releases.

I do have currently 2 accounts:
1 is an IMAP acocunt, which is not corrupted (work) and the other account is a
pop used for mailing list. The pop account folder has different subfolders for
each mailing list. I do not know why, but the headers and messages are
mismatched. Since the headers are mismatched filtering is malfunctioning.
Just wanted to say, I am having the same problem.
I have both a pop3 and imap account with filters from
the pop3 account to the imap account.

I have not been able to figure out the sequence to reproduce this.
Sometimes my headers are fine, sometimes they are mismatched.

I am using w2k sp 3 with Moz 1.3a.
Just wanted to say, I am having the same problem.
I have both a pop3 and imap account with filters from
the pop3 account to the imap account.

I have not been able to figure out the sequence to reproduce this.
Sometimes my headers are fine, sometimes they are mismatched.

I am using w2k sp 3 with Moz 1.3a.

Reproduced with "Thunderbird", standalone Mozilla mail client, official windows
builds 2003-07-08 and 2003-07-16. Also submitted in "Thunderbird Bugs" forum at
forums.mozillazine.org.

Here is a full description.

Recently I receive an account on IMAP server and decided to keep my mail here.
So I customize filters  to automatically copy some mails which I receive in
other POP account to the different folders in IMAP server (in common way). Both
POP and IMAP accounts have options "Check for new messages at startup" and
"Automatically download new messages" enabled. When I start TB, it starts to
check for new messages in both IMAP and POP server and when I have many messages
coming from POP server  (this is common thing in the morning), they are
processed by filters, but often message something like "Cannot apply filter
<filtername> - folder is processed" appears (these filters should move messages
to IMAP folder). Even if there is no such errors, after filtering I have my
messages cutted in a strange way - message which I select shows body from
different mails (beginning or not), sometimes I also has sticked messages - when
I scroll body down, I can see headers and bodies of other messages. It seems to
me that here is some mess between "indices" (file xxx.msf) and folders content
(file xxx) appear.
I encountered this problem with both Mozila 1.4 and Thunderbird 0.2 on Mac OS X
(10.2.6). The destination IMAP server is uw-imap-ssl and is running on the same
box. Mail that matches the filter criteria doesn't move, and the POP box becomes
corrupted. Filters seem to work okay when moving mail from remote IMAP servers
to the local IMAP servers.
So, what's the game plan to kick this dataloss?
I have not experienced dataloss, but there is (almost 2 years after this bug has
been reported) still a problem with filtering from incoming pop-mail to an imap
folder. In both Mozilla 1.7 and Thunderbird 0.7.1 (both on Linux)
To reproduce, look at bug #210614.

Hoping this gets fixed.
Product: MailNews → Core
shouldn't this also be marked fixed?
resolving as dup

*** This bug has been marked as a duplicate of 210614 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.