Last Comment Bug 180112 - Arabic combining diacritical marks are rendered separately, not above or below the characters
: Arabic combining diacritical marks are rendered separately, not above or belo...
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: Trunk
: x86 All
: -- normal with 14 votes (vote)
: ---
Assigned To: Mike Kaply [:mkaply]
:
:
Mentors:
: 181669 257101 306068 397603 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-14 06:32 PST by Roland Unger
Modified: 2008-07-31 02:39 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
HTML file with Arabic text and diacritical marks (313 bytes, text/html)
2002-11-14 06:35 PST, Roland Unger
no flags Details
Screenshot in Windows showing display of Arabic diacritics fine (12.86 KB, image/png)
2003-09-29 01:08 PDT, Ossama Khayat
no flags Details
A test case in RH9 using Mozilla 1.4 (455 bytes, text/html)
2003-09-29 01:53 PDT, Ossama Khayat
no flags Details
A screenshot of the previous (test2.html) test page. (44.88 KB, image/png)
2003-09-29 01:55 PDT, Ossama Khayat
no flags Details
HTML file with Arabic text and diacritical marks - extended - (549 bytes, text/html)
2003-10-08 08:01 PDT, Roland Unger
no flags Details
A screenshot of the previous (test.html) test page - Win 98 - M1.5 RC2 (16.32 KB, image/gif)
2003-10-08 08:06 PDT, Roland Unger
no flags Details
A screenshot of the previous (test.html) test page - Win 2000 - M1.5 RC2 (30.64 KB, image/gif)
2003-10-08 08:09 PDT, Roland Unger
no flags Details
Screenshot of unicode UTF-8 vietnamese characters (44.51 KB, image/jpeg)
2004-09-15 03:25 PDT, John O'Shea
no flags Details
Both bad and good rendering (153.47 KB, image/jpeg)
2005-08-26 12:14 PDT, Vít Zvánovec
no flags Details

Description Roland Unger 2002-11-14 06:32:00 PST
User-Agent:       Mozilla/4.78 [en] (Win98; U)
Build Identifier: 2002101612

As a part of the Arabic Unicode plane, some combining diacritical marks (for 
instance Fatha, Kasra and so on) are defined. Mozilla does not render a 
combination, but two separate characters.

Reproducible: Always

Steps to Reproduce:
1.See attached test file.
2.
3.
Comment 1 Roland Unger 2002-11-14 06:35:37 PST
Created attachment 106212 [details]
HTML file with Arabic text and diacritical marks

UTF-8 coded test file containing an English title and three Arabic words
(shukran, kurrasa, mu'allim) with their diacritical marks.
Comment 2 Niklas Dougherty 2002-11-15 22:00:09 PST
This is because of Mozilla's severe limitations rendering Unicode. See bug
157967 for details.
Comment 3 Tim Freedom 2003-09-29 00:25:47 PDT
This is a critical bug for proper Arabic - any further status and/or movement to
eradicate this problem (its been awhile since it was looked into) ?
Comment 4 Ossama Khayat 2003-09-29 01:06:24 PDT
This works fine in Windows.
The problem still in exists in Linux though.
I'll try to attach a screenshot using Linux and the latest nightly build.
Comment 5 Ossama Khayat 2003-09-29 01:08:17 PDT
Created attachment 132338 [details]
Screenshot in Windows showing display of Arabic diacritics fine

As you can see in the shot, I'm using a nightly build (20030924) and Windows
XP.
Comment 6 Ossama Khayat 2003-09-29 01:53:02 PDT
Created attachment 132341 [details]
A test case in RH9 using Mozilla 1.4

The first line has broken words on diacritics, but not the second line (where
there isn't a font specified!).
Comment 7 Ossama Khayat 2003-09-29 01:55:17 PDT
Created attachment 132342 [details]
A screenshot of the previous (test2.html) test page.

This is how it look on my RH9 machine. BTW, I have fonts-arabic RPM package
installed as well as ae_fonts.
Comment 8 Pierrick Brihaye 2003-10-08 03:12:13 PDT
Additional comment #5 says :

>Screenshot in Windows showing display of Arabic diacritics fine

This is *not* true on Windows 98 (either using Mozilla 1.4, 1.5RC2 or NS 7.02).
Comment 9 Roland Unger 2003-10-08 08:01:22 PDT
Created attachment 132874 [details]
HTML file with Arabic text and diacritical marks - extended -

UTF-8 coded test file containing an English title and three Arabic words
(shukran, kurrasa, mu'allim) with their diacritical marks. The text is
written twice; the second time with the font Traditional Arabic to test
OpenFont properties
Comment 10 Roland Unger 2003-10-08 08:06:55 PDT
Created attachment 132876 [details]
A screenshot of the previous (test.html) test page - Win 98 - M1.5 RC2 

In case of Windows 98, Arabic combining diacritical marks are rendered
separately.
Arabic Support installed. Correct working with IE 6 and MS Word
Comment 11 Roland Unger 2003-10-08 08:09:55 PDT
Created attachment 132877 [details]
A screenshot of the previous (test.html) test page - Win 2000 - M1.5 RC2

In case of Windows 2000 and Mozilla 1.5 RC2 it works correctly.
Comment 12 Asa Dotzler [:asa] 2004-03-09 13:59:16 PST
*** Bug 181669 has been marked as a duplicate of this bug. ***
Comment 13 Simon Montagu :smontagu 2004-08-27 10:41:22 PDT
*** Bug 257101 has been marked as a duplicate of this bug. ***
Comment 14 John O'Shea 2004-09-15 03:25:51 PDT
Created attachment 158963 [details]
Screenshot of unicode UTF-8 vietnamese characters

Attached screenshot shows combining diacriticals not displaying correctly in a
utf-8-encoded Vietnamese file. Same file displays correctly in Safari.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913
Firefox/0.10
Comment 15 Vít Zvánovec 2005-08-26 12:14:56 PDT
Created attachment 193952 [details]
Both bad and good rendering
Comment 16 Uri Bernstein (Google) 2005-08-26 12:19:24 PDT
*** Bug 306068 has been marked as a duplicate of this bug. ***
Comment 17 Uri Bernstein (Google) 2005-08-26 12:22:07 PDT
Please note that two of the recent dupes were for non en-US (French and Czech)
installations on Windows 2000/XP.
Changing OS to "All".
Comment 18 Jungshik Shin 2005-08-26 17:13:41 PDT
(In reply to comment #17)
> Please note that two of the recent dupes were for non en-US (French and Czech)
> installations on Windows 2000/XP.

On Windows 2k/XP, that should work fine. It doesn't work there (in cases of two
dupes) because they didn't turn on 'complex script' support in Control Panel |
Regional&Lang. setting. MS IE just works even without it (because MS IE directly
uses Uniscribe APIs), but Firefox does need that to be turned on. (see bug 218887)

> Changing OS to "All".

Well, this bug on its own is all but useless. It's just a dupe of several
complex script rendering bugs on different platforms. 

Comment 19 Johan Laenen 2007-01-01 04:11:43 PST
Mozilla 1.7.8, in fact 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20061113 Debian/1.7.8-1sarge8 displays the diacritical marks seperate, see https://bugzilla.mozilla.org/attachment.cgi?id=132874, while firefox 1.5.0.7 (Mozilla/5.0, X11; U; Linux i686; en-US; rv:1.8.0.7, Gecko/20060830) does it correctly.
Comment 20 Khaled Hosny 2007-09-11 16:44:10 PDT
The text is rendered correctly in both firefox-2.0.0.6 with pango enabled under linux, and firefox-3.0a8pre.en-US with default settings under linux too.
Comment 21 Simon Montagu :smontagu 2007-09-16 08:53:05 PDT
WORKSFORME on all platforms (except for the incorrect placement of the combining diacritical marks on Mac, which is bug 386573)
Comment 22 Simon Montagu :smontagu 2007-09-25 23:06:13 PDT
*** Bug 397603 has been marked as a duplicate of this bug. ***
Comment 23 Karunia 2007-09-26 00:06:55 PDT
i use firefox 2.0.0.7 under winxp & under win9x, the diacritical marks is still separated. but when i use windows arabic enabled, it render fine. i wait since firefox 1 until the 2.0.0.7 version, it still like that. then i try to find other ways to rendering arabic text. you can visit url: http://www.matamaya.com/encoder.htm i try to manipulate the render using javascript encoder. it works!!! but only the first line! the next lines all diacritical marks are gone! see my other bug: Bug 397325

Note You need to log in before you can comment on or make changes to this bug.