Javascript links do not work in this web page

VERIFIED WONTFIX

Status

VERIFIED WONTFIX
16 years ago
4 years ago

People

(Reporter: pedro.madeira, Assigned: tristan)

Tracking

({testcase})

Details

(Whiteboard: [havefix][havecontact], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

The orange links that contain javascript in this site do not work in mozilla

Reproducible: Always

Steps to Reproduce:

Comment 1

16 years ago
From JavaScript console:

Error: missing variable name
Source File: http://www.exit.pt/libraries/lib_utils.js
Line: 27, Column: 6
Source Code:
		var final = '$00';

Error: resv is not defined
Source File: http://www.exit.pt/?lnk=ifv,0&infotype=pacotes&infoid=22859
Line: 974

Not sure this is Tech Evangelism, it should work.
Summary: Java links do not work in this web page → Javascript links do not work in this web page

Comment 2

16 years ago
Created attachment 106213 [details]
Reduced testcase

Updated

16 years ago
Keywords: testcase
OS: Linux → All

Comment 3

16 years ago
From testcase, Mozilla is acting properly. |resv| is not correctly declared
within the JavaScript function. It has no way of knowing what |resv| is,
according to scope. It needs to be referenced by |document.getElementById|,
|document.forms|, or similar:

var resv = document.getElementById("resv");
var resv = document.forms["resv"];

I'm not certain what the "$00" problem is, but it could be related.

-> Tech Evangelism
Assignee: rogerl → nitot
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Europe: West
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → brantgurganus2001
Version: other → unspecified

Comment 4

16 years ago
> I'm not certain what the "$00" problem is, but it could be related.

The problem is the use of "final" as the identifier name:

                       var final = '$00';

See the ECMA-262 Ed.3 spec for the language, Section 7.5.3: "final"
is a reserved word and may not be used as an identifier name.

The spec is visible at http://www.mozilla.org/js/language
yup, they shouldnt use final.
Whiteboard: [havefix]
(Reporter)

Comment 6

16 years ago
I changing this to invalid since the problem is from the website's variables
name used.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
so this is a perfectly valid technology evangelism bug. we just need to let them
know about the problem and the _easy_ fix.
reopening. dont close tech evang bug like this please. is the problem still here
? do we have a valid contact to give them this information ?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 8

16 years ago
exit@exit.pt
source: http://www.exit.pt/?lnk=aju,2
Whiteboard: [havefix] → [havefix][havecontact]
can anyone contact them about the [easy] fix ?
(Reporter)

Comment 10

16 years ago
client support mail account:

exit@exit.pt
(Reporter)

Comment 11

16 years ago
TE so changing to WontFix
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX

Comment 12

16 years ago
v
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → Portuguese
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.