Attachment list not shown after viewing mail with lots of attachments

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: bkuemmer, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021113

If you select a mail message with a lot of attachments (e.g. a mailing list 
digest) so that the attachment box gets a scrollbar and then afterwards you 
select a message with only one attachment, the attachment is not shown in the
attachment box. It seems that it is scrolled out of the visible area, but
without a scrollbar. With a scroll-wheel-mouse, you can make the attachment 
visible again.

Reproducible: Always

Steps to Reproduce:
1. Select a mail message with >4 attachments
2. Select a mail message with few (1 or 2) attachments


Actual Results:  
The attachment box does not show any attachment. The attachment shows up if 
you scroll up with a scroll wheel mouse.

Expected Results:  
The attachment should have been visible after step 2.

It seems that this could be related to bug #138, feel free to mark as duplicate
if necessary
(Reporter)

Comment 1

16 years ago
Sorry, I meant bug #138574
(Reporter)

Comment 2

16 years ago
Really sorry, wrong again, I meant bug #145019

Updated

16 years ago
QA Contact: olgam → yulian

Comment 3

16 years ago
I've experienced this under both Win2k and Linux with versions probably
beginning somewhere around 1.1. Just experienced it now under Linux with 1.2.  I
can't always reproduce it the way the reporter describes (or in any other way I
know of). The fix by using the scrolling wheel on the mouse works though.
QA Contact: yulian → stephend

Comment 4

16 years ago
I experience this frequently myself, but I am having trouble reproducing it. At
least for me it is not as simple as switching between messages with many and few
attachments. 

I am running Mozilla 1.3b build 2003021008 on Windows XP. It seems to happen
most frequently while running some other processor intensive application like an
internet streaming TV app we have at my college. What I do know is that when
this happens Mozilla still chooses when to draw the attachments window
correctly. Furthermore, right-clicking the attachments area and choosing "Save
All..." will save the files even though they are not displayed. Finally,
scrolling the attachments list (the scrollbar is drawn even though there are no
files listed) will fix it, as well as restarting Mozilla.

Comment 5

15 years ago
Reporter, do you still see this problem with the latest nightly (or even 1.5)?
If not, this bug can be closed. Thanks.
(Reporter)

Comment 6

15 years ago
OK, this seems to be fixed in 1.5, at least I can't reproduce it
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.