Closed Bug 180144 Opened 17 years ago Closed 8 years ago

Filter editing UI: filter conditions group can fail to have a scroll bar if sized too small - so it seems unable to have multiple criteria, rules are missing

Categories

(MailNews Core :: Filters, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 5.0b1

People

(Reporter: todd.pederzani, Assigned: rkent)

References

(Depends on 1 open bug, )

Details

(Keywords: polish, Whiteboard: [gs] [has patch for review])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021114
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021114

When editing a filter, the box that contains the conditions for the filter can
be missing a scroll bar if your dialog is sized small enough vertically.

Reproducible: Always

Steps to Reproduce:
1. Edit a message filter
2. Resize your window vertically so that you can only see part of the text of
the condition to match
3. Click on the "More" button to add another filter condition
Actual Results:  
If you've sized your window small enough, even though another condition was
added, no scroll bar will be visible.  If you resize your window now, you can
get the scrollbar to appear - mine did when the first pixel of the condition box
for the second condition appeared.


I'm using the classic theme on a nightly I downloaded this morning.  This caused
me a bit of confusion initially, as my window was sized perfectly to trigger the
bug; I thought the additional conditions were not being added.
*** Bug 190519 has been marked as a duplicate of this bug. ***
*** Bug 193165 has been marked as a duplicate of this bug. ***
*** Bug 191639 has been marked as a duplicate of this bug. ***
Confirming. I hope to tackle this within the next two weeks, but if someone
wants to fix this sooner (or if I don't find time after all), please don't let
that stop you. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
OS: Windows XP → Windows 98
*** Bug 180137 has been marked as a duplicate of this bug. ***
Summary: Filter editing UI: filter conditions group can fail to have a scroll bar → Filter editing UI: filter conditions group can fail to have a scroll bar if sized too small - so it seems unable to have multiple criteria
*** Bug 194250 has been marked as a duplicate of this bug. ***
People should no longer see this occurring without having resized the window 
themselves due to the fix for bug 183994. Don't know if the underlying problem 
is fixed as well - will check with a nightly in a few days. (If so, this is a 
dupe.) Regardless, this is not something I'm going to do anymore.
mass re-assign.
Assignee: naving → sspitzer
Per comment 7: underlying problem is not fixed, duplicated in 
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Depends on: 184998
Product: MailNews → Core
No longer depends on: 184998
Depends on: 292284
This bug can be easily addressed with the same fix described at 
bug 297006 comment 10 -- that one CSS tweak fixes the problem here and 
at that bug, as the ID of the criteria box is the same is all those dialogs.
Severity: normal → minor
OS: Windows 98 → All
Hardware: PC → All
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: laurel → filters
Product: Core → MailNews Core
Depends on: 297006
Duplicate of this bug: 178488
Duplicate of this bug: 555165
kent, I collected all the gsfn examples I could find into http://gsfn.us/t/qu2u
Assignee: nobody → kent
Severity: minor → normal
Status: NEW → ASSIGNED
No longer depends on: 297006
See Also: → 297006
Summary: Filter editing UI: filter conditions group can fail to have a scroll bar if sized too small - so it seems unable to have multiple criteria → Filter editing UI: filter conditions group can fail to have a scroll bar if sized too small - so it seems unable to have multiple criteria, rules are missing
Whiteboard: [gs]
Duplicate of this bug: 612298
Duplicate of this bug: 579294
Duplicate of this bug: 605293
I consolidated several more gfsn articles.

xref Bug 205039 - Filter Rules window needs a splitter
Duplicate of this bug: 583092
This bug has become a collecting point for a very common user support issue, when they set the filter dialog too small somehow, and lose critical UI elements.

Though I rarely venture into UI fixes, either I'm missing something, or we just need to set some minimum heights here. So let me toss this patch into the hopper, and see what the real UI people think (or inspire them to propose something better).
Attachment #528541 - Flags: review?(bwinton)
Whiteboard: [gs] → [gs] [has patch for review]
Comment on attachment 528541 [details] [diff] [review]
Set minimum heights

Review of attachment 528541 [details] [diff] [review]:

This certainly seems better, but I wonder if we can also set a minimum size on the dialog as a whole…

Oh, and I think we want some sort of minimum width, since resizing horizontally really messes things up, but it mostly fixes itself if we then resize vertically…

So, all in all, a bunch of weird things are happening here, and while I think this patch makes some of them a little better, I think there's still a bunch of work to do.

Uh, I guess that translates into r=me, but I would appreciate it if you did a little more on this.  ;)

Thanks,
Blake.
Attachment #528541 - Flags: review?(bwinton) → review+
"I would appreciate it if you did a little more on this"

Yes it needs more work. I keep hoping that someone who is more familiar with issues in front end bugs will get motivated to work on this. But for now, I'm tired of the support issues on this, and just want to solve the worst pain point.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a4
You need to log in before you can comment on or make changes to this bug.