[junk mail] analyze "new" local messages, after they've been filtered to an open folder

VERIFIED FIXED in mozilla1.4final

Status

VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: sspitzer, Assigned: Bienvenu)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.4final

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

[junk mail] analyze "new" local messages, after they've been filtered, like we
do with imap messages

from granrose:

1)  he filters pop mail from inbox to folder x.
2)  since filters execute before bayesian plugin, then don't get analyzed
3)  open folder x, and we don't analyze the messages we filtered (like we do
with imap) since they aren't new.

should we just keep them as new, after moving them?
(Assignee)

Comment 1

16 years ago
I said that I would do this, so unless you're looking for stuff to do, Dan, I
can look at this.
Assignee: dmose → bienvenu
blocks 11035, which is our meta bug for this work
Blocks: 11035

Updated

16 years ago
QA Contact: olgam → laurel
OS: Windows 2000 → All
Hardware: PC → All

Comment 3

16 years ago
This appears to be a dupe of bug 179639.
(Assignee)

Comment 4

16 years ago
*** Bug 179639 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

16 years ago
Created attachment 106808 [details] [diff] [review]
proposed fix
(Assignee)

Comment 6

16 years ago
Dan, can I get an r=? thx.
Comment on attachment 106808 [details] [diff] [review]
proposed fix

sr=sspitzer

you'll make pop users who filter (like granrose) happy with this one.
Attachment #106808 - Flags: superreview+
Comment on attachment 106808 [details] [diff] [review]
proposed fix

r=dmose
Attachment #106808 - Flags: review+
(Assignee)

Comment 9

16 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 10

16 years ago
woohoo!  I'll try it tonight.
(Assignee)

Comment 11

16 years ago
Please let me know. It was easy. Too easy :-)

Comment 12

16 years ago
looks good.  It's analyzing new messages in the Inbox folders for my secondary
accounts when I enter them.  I noticed for two of my accounts it left one
message each with an "unknown" status rather than marking it junk or non-junk,
so I wonder if it's not having something similar to the IMAP problem where it
used to leave one message unanalyzed.  Although a non-inbox folder in my
secondary account it apparently analyzed all of them.

somewhat related rfe: would be nice if there were a way you could select to have
it analyze messages that are in the "unknown" status even if they're not new. 
This would come in handy in my webmail account since I read that all over the
place so every time I switch between home and work, any read mail that is new in
this profile shows up "unknown".  Probably too much stress on the server for
IMAP, but don't see any reason for it not to work on POP (although that's less
useful).

Comment 13

16 years ago
granrose, something like "Tools / Run Junk Mail Controls on Selected Messages" ?

And: thanks, the filter works great here (no mistake among about 50-100
automatically marked messages) and the fix to this bug report left no message
undefined here yet!!

Comment 14

16 years ago
andreas:  doh!  I meant something to analyze unknown messages *automatically*
every time you enter a folder, so you wouldn't have to do "run junk mail
controls" manually.

Comment 15

16 years ago
Doesn't this fix reverse the logic of creating a filter TO MOVE a message that
is JUNK MAIL status of = "junk" to a separate folder ???

I know this filter can be created in MESSAGE FILTERS (but didnt work
Automatically before, and definitely wldnt now that Junk Mail is marked AFTER
mail moves) ...  Is the ONLY way to *automatically* move a message that is
labelled as Junk to a "SPAM" folder to use the Junk Mail controls (the ones that
are currently blocked out in the code in junkmail.js) ??? 

And, users would only be able to create *after-the-fact* filters based on
message Junk Mail labels (basically, you can create a filter that says ... MOVE
any mail labelled as JUNK to Trash ... but you could only choose to RUN it on
directories .. b/c it wld never work automatically) ... 


(Assignee)

Comment 16

16 years ago
Andrew, I don't really know what you're talking about. Junk was always marked
after filter moves; that's the problem that this fixes. You don't have to have
the  junk messages moved to the spam folder by the built-in junk filter.

Comment 17

16 years ago
I don't know if you already are aware of that:
While this fix enabled junk scanning in folders where pop mail went after
sorting (it is now scanned upon first access to this folder), the case when you
already *are* in a folder different from your inbox seems to be left:

Say you have folder foo as subfolder of your Inbox and set your message filters
to put certain mails there. Then everything works fine when you are in another
folder (i.e. e.g. viewing your Inbox mails) while downloading your pop mail: the
foo folder is scanned for junk on first access.

BUT when you already are in the foo folder while downloading new messages, then
the mails filtered to the foo folder will NEITHER be examined by the junk mail
controls directly after the download/filtering NOR when you leave and re-enter
the foo folder.

Maybe that is what granrose experienced when he wrote about mails that were left
"unknown". And maybe (if you can reproduce it) this bug should be reopened for
fixing it... 
(Assignee)

Comment 18

16 years ago
Andreas, no, I didn't realize that, but it makes sense. That's not going to be
so easy to fix. Sigh. I'm tempted to open a new bug for that but I guess I'll
reopen this and change the summary so the people on the cc list won't have to move.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: [junk mail] analyze "new" local messages, after they've been filtered, like we do with imap messages → [junk mail] analyze "new" local messages, after they've been filtered to an open folder

Comment 19

16 years ago
*** Bug 181912 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
The Problem seems to be solved width the Trunk from 2002-11-26 (Mozilla/5.0
(Windows; U; Win98; en-US; rv:1.3a) Gecko/20021126)

Comment 21

16 years ago
Not sure whether the folowing belongs to this bug, but it is rather similar:

Having various pop accounts I filter all incoming mail from AccountX/Inbox to
LocalFolders/Inbox/AccX (x = 1,2,...).
While moving mail within one pop account to sub folders of the inbox and still
get the filtering for junk, this definetly doesn't work, if you move the
messages to LocalFolders/somewhere with message filters.
Only option available is to run the junk mail scan manually after each get
messages. Annoying.
(Build 20030115)

Any comments?

Comment 22

16 years ago
*** Bug 197056 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 23

16 years ago
Created attachment 123402 [details] [diff] [review]
proposed fix

the fix is to run the junk mail controls on the currently displayed folder if
it's not the inbox and it has new messages after getting new pop3 mail.
(Assignee)

Comment 24

16 years ago
Created attachment 123405 [details] [diff] [review]
proposed fix

need to add null check for folder.
Attachment #123402 - Attachment is obsolete: true
Comment on attachment 123405 [details] [diff] [review]
proposed fix

r/sr/a=sspitzer

can you double check that there are no ownership cycles introduced?

also, per scc, do:

NS_IF_ADDREF(*aMsgWindow = m_msgWindow);
Attachment #123405 - Flags: superreview+
Attachment #123405 - Flags: review+
Attachment #123405 - Flags: approval1.4+
should land for 1.4 final.
Status: REOPENED → ASSIGNED
Keywords: nsbeta1
Target Milestone: --- → mozilla1.4final
(Assignee)

Comment 27

16 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 28

16 years ago
using trunk build 20030521 on winxp, macosx and linux this works for POP to
Local and POP to POP but not for IMAP filtering to a POP or Local folder.  I
know this was specifically logged for POP to Local, but I wanted to try IMAP too
since we just fixed the bug where the move or copy didn't hold the Junk Icon. 
Should I reopen this or log a new bug.  
(Assignee)

Comment 29

16 years ago
Esther, please log a new bug for the imap -> local case.

Comment 30

16 years ago
OK, verified  new bug for imap to pop/local is bug 206679
Status: RESOLVED → VERIFIED

Updated

16 years ago
QA Contact: laurel → esther

Comment 31

15 years ago
*** Bug 192499 has been marked as a duplicate of this bug. ***

Comment 32

15 years ago
*** Bug 204850 has been marked as a duplicate of this bug. ***

Comment 33

15 years ago
Is there a bug that deals with marking messages as spam, even if they should be
getting filtered?  I did a number of bugzilla searches, but this seemed to be
the only related bug.

BTW, I would also love to be able move the junk mail filter around in the
"Message Filters" dialog to prioritize it relative to my other filters.  I'll
create a bug for this second item.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.