Sidebar panels not showing up in My Panels of Mail 3 pane

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: daver, Assigned: Steve Lamm)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
In today's build (11/4/99) and in past builds, when you slide my panels up, none
of the default sidebar panels are there like what useless, tinderbox, etc.

Updated

19 years ago
Assignee: phil → hangas

Comment 1

19 years ago
Reassign to hangas
(Assignee)

Comment 2

19 years ago
I will check this out when my morning build finishes.

Looking messenger.xul and msgMail3PaneWindow.js, I see a few things things that
need tweeking, but not anything that should cause this bug.

Updated

19 years ago
Assignee: hangas → slamm
(Assignee)

Comment 3

19 years ago
Chris, I do not see any obvious reason why the panels are not showing up in the
Mail window. They sidebar template is getting applied since the "My Panels"
splitter is create. For some reason the individual panels are not created. Is
the brutal sharing messing this up?

Comment 4

19 years ago
it's possible, but I kinda doubt it. sounds similar to the bug where sidebar
doesn't show up after "View Sidebar"
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

19 years ago
I figured it out. The sidebarOverlayInit() function tries to set the value of
"menu_sidebar" which is the "View / Sidebar" menu. I have a change that checks
if the menu is there. We can also decide if we want to add the menu item to
messenger. Paul, will you review the patch? I will attach it.
(Assignee)

Comment 6

19 years ago
Created attachment 2672 [details] [diff] [review]
Patch for sidebarOverlay.js (Test for menu before setting it)
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
I checked in the fix.
(Assignee)

Comment 8

19 years ago
*** Bug 17662 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
verified 1999-11-09-11-m11 commercial win32 build.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.