Mozilla incorrectly renames the files according to MIME type.

VERIFIED DUPLICATE of bug 144334

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 144334
16 years ago
14 years ago

People

(Reporter: Lev Povalahev, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021113

Mozilla (1.2 latest & 1.3 latest) does not handle downloads correctly.
If the MIME type is not specified and the file is send via script mozilla takes
the extension of the script and adds it to the file name. Example: many of the
files on www.cracks.am  (http://www.cracks.am/d.x?24582)

If the mime type is specified mozilla adds the extension of the mime type to the
filename (i.e. if you download a file a.tar.gz with mime type application/x-tar
it becomes a.tar.gz.tar). Mozilla also does not look for the file extension but
only at the extension of mime type. This is wrong. example:
http://www.python.org/doc/current/download.html (html downloads (zip, gzip, bz2))
I have winzip assosiated with .zip and .gz files, but powerarchiver with .bz2
files. But mozilla simply takes the extension of the mime type
(application/x-tar), which is .tar and want to open all files with
winzip(assosiated with .tar) instead of using correct application for .bz2 files.

This bug persists for a loooong time now.

I'm using WinXP + SP1


Reproducible: Always

Steps to Reproduce:

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 144334 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.