Cookies are not save to disk when quitting Mozilla

VERIFIED FIXED

Status

()

Core
Networking: Cookies
--
critical
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Gilles Durys, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
2002111410 trunk win xp

Launch Mozilla.
Go to page that sets cookie.
Quit Mozilla.

Actual results: The cookies.txt only contains the 4 commented lines.

Works in 2002111311 trunk win xp
(Assignee)

Comment 1

16 years ago
That's very strange.  Absolutely nothing has changed in this code for quite a
while, certainly not in the last day.

tever, can you verify this?

Comment 2

16 years ago
on linux, all my cookies actually vanished on exit, and i used to have a lot.
Cookie manager was clean empty when i opened it after a fresh start.

Comment 3

16 years ago
fix for bug 175320 was backed out with this comment:

"Backout checkin for bug #175320. It was causing cookie files to be saved
without any entries but still with the standard "This is a generated file!" header."
(Reporter)

Comment 4

16 years ago
Marking FIXED since the patch from bug #175320 has been backued out.

It works on 2002111422 linux trunk.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

16 years ago
*** Bug 180387 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
yes backing out the patch in bug 175320 fixed this
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.