Closed Bug 1802305 Opened 1 year ago Closed 1 year ago

Update PDF.js to new version 823723121de9e8448ecb61ed04a93e1eb4bd9799 from 2022-11-24 11:44:19

Categories

(Firefox :: PDF Viewer, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
109 Branch
Tracking Status
firefox109 --- fixed

People

(Reporter: update-bot, Assigned: calixte)

References

(Blocks 1 open bug)

Details

(Whiteboard: [3pl-filed][task_id: TCk1Wq7dQJuLTcsZH6K3mA])

Attachments

(1 file)

This update covers 6 commits:


9f5e1f48182c8d61e3017ead0766218b2084b536 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/9f5e1f48182c8d61e3017ead0766218b2084b536
Authored: 2022-11-24 12:37:07 +0100
Committed: 2022-11-24 12:37:07 +0100

Revert "Remove the overflowing text special-case from scrollIntoView (issue 15714)"

Files Modified:

  • web/ui_utils.js

47682985d34c0edc79a8a4a37597e9a0ed51530c by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/47682985d34c0edc79a8a4a37597e9a0ed51530c
Authored: 2022-11-23 12:58:00 +0100
Committed: 2022-11-23 12:58:00 +0100

Add support for Optional Content in TilingPatterns (issue 15716)

This can't be a particularly common feature, since we've supported Optional Content for over two years and this is the very first TilingPattern-case we've seen.

Files Added:

  • test/pdfs/issue15716.pdf

Files Modified:

  • src/display/api.js
  • src/display/canvas.js
  • test/pdfs/.gitignore
  • test/test_manifest.json

f3e0f866412ac7c4d04afef9cadd9b6433e32602 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/f3e0f866412ac7c4d04afef9cadd9b6433e32602
Authored: 2022-11-23 11:48:08 +0100
Committed: 2022-11-23 11:48:08 +0100

Simplify the getFilenameFromUrl helper function

Files Modified:

  • src/display/display_utils.js

38dd219d858da8056caeb8506479aa3836d55a35 by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/38dd219d858da8056caeb8506479aa3836d55a35
Authored: 2022-11-22 17:48:53 +0100
Committed: 2022-11-23 11:17:58 +0100

Unblock the load event when the pdf has a password (bug 1801341)

Files Modified:

  • web/app.js

0ba242ea4a674aeb5ef0e15248931824fba5da38 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/0ba242ea4a674aeb5ef0e15248931824fba5da38
Authored: 2022-11-23 10:40:30 +0100
Committed: 2022-11-23 10:47:33 +0100

Support FileAttachments with hash-signs in the filename (issue 15729)

The reason for the issue is that we use the generic getFilenameFromUrl helper function, which was originally intended for regular URLs.
For the filenames we're dealing with in FileAttachments, we really only want to strip the path when one exists[1].


[1] See bug 1230933 for an example of such a case.

Files Modified:

  • src/display/annotation_layer.js
  • src/display/display_utils.js
  • test/unit/display_utils_spec.js
  • web/pdf_attachment_viewer.js

0ff43b27bb514471116fc8c2d395592b75fa48bb by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/0ff43b27bb514471116fc8c2d395592b75fa48bb
Authored: 2022-11-22 11:54:30 +0100
Committed: 2022-11-22 11:54:30 +0100

Remove the overflowing text special-case from scrollIntoView (issue 15714)

With the changes made in PR 14564 this should no longer be necessary now, however we still need to keep the scrollMatches parameter to handle textLayers with markedContent correctly when searching.

Files Modified:

  • web/ui_utils.js

All jobs completed, we found the following issues.

Needs Investigation (Other Failed Jobs):
test-linux1804-64-qr/debug-mochitest-devtools-chrome-swr-1
- 4 of 4 failed on the same (retriggered) task (Fr_Lati7TZenF9eQGuvhHQ, BMBiBJMjR92y30b_ujF5gg, ExbBKDJbQaO1eX-GRs7MyQ, fYfs470cS-WFDkeZQX8l5A)
test-linux1804-64-qr/debug-mochitest-devtools-chrome-spi-nw-1
- 4 of 4 failed on the same (retriggered) task (J3c2h4lmTr605ehwas8pHg, HY0rlSzAR-ShpoMwF3sDzw, IlO7mpOHT2eKlfKgKwo_Zg, LRfHF1wsTGa-CCm5JtOWUQ)
test-linux1804-64-qr/debug-mochitest-devtools-chrome-1
- 4 of 4 failed on the same (retriggered) task (Mpntv_yERUSeLdElKJNEmg, EGGtHWDTQACd2pKzudowww, PGXp9fqdT0GyVtAIP0Hlwg, ZBfJST1dRQK49zQ0ZNt6EA)
test-macosx1015-64-qr/debug-mochitest-devtools-chrome-1
- 4 of 4 failed on the same (retriggered) task (erGdzpvoQYOcRCyQS9GUmQ, fY_ekDtfTlWBmuyv6-mleA, Qs7vXmafRLyANYjOHmruUQ, SbrZET-wQGqryZL7lOGtJg)
test-macosx1015-64-qr/debug-mochitest-devtools-chrome-spi-nw-1
- 4 of 4 failed on the same (retriggered) task (YSyqphf8RnSqC3OqNj39eQ, GrhVsu07Qc2mvkZdWotJbQ, W0GwMN6eTY-dOQjNhpKpYw, TmBPjHRHRcGlrsaj0xbdYA)
test-windows10-64-2004-qr/debug-mochitest-devtools-chrome-spi-nw-1
- 4 of 4 failed on the same (retriggered) task (bTw4TrPARVaqWKLnkVjTtQ, CpAvIdYARMepJ3rYVuuM_w, EcN8yJgNSwSmiuhrt8HCqQ, Q8_DmzSbQw6eVhh4h_ZREA)
test-windows10-64-2004-qr/debug-mochitest-devtools-chrome-1
- 4 of 4 failed on the same (retriggered) task (Di4H4yMaRpaT4oaJYQQ07w, P28ww2q3QSqhU3nTe4Kmig, Tm7mtkCWTPi8JtAdMRhH4Q, TKcobcAvQKukcJxq29x8KA)

These failures may mean that the library update succeeded; you'll need to review
them yourself and decide. If there are lint failures, you will need to fix them in
a follow-up patch. (Or ignore the patch I made, and recreate it yourself with
./mach vendor toolkit/components/pdfjs/moz.yaml.)

In either event, I have done all I can, so you will need to take it from here.
When reviewing, please note that this is external code, which needs a full and
careful inspection - not a rubberstamp.

Assignee: nobody → cdenizet

Updatebot encountered an error while trying to set you as a reviewer in phabricator.
Updatebot will be unable to do anything more for this library version.

Flags: needinfo?(cdenizet)
Pushed by cdenizet@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/49de14a8d40d
Update PDF.js to 823723121de9e8448ecb61ed04a93e1eb4bd9799 r=pdfjs-reviewers,calixte
Flags: needinfo?(cdenizet)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch

(In reply to Update Bot from comment #4)

Updatebot encountered an error while trying to set you as a reviewer in phabricator.
Updatebot will be unable to do anything more for this library version.

This issue will be fixed in https://github.com/mozilla-services/updatebot/pull/303

You need to log in before you can comment on or make changes to this bug.