Closed Bug 1802701 Opened 1 year ago Closed 1 year ago

"Manage Cookies and Site Data" dialog is too tall

Categories

(Firefox :: Settings UI, defect)

Firefox 108
x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
109 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox107 --- unaffected
firefox108 --- verified
firefox109 --- verified

People

(Reporter: 6k64x4ma, Assigned: emilio)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

Attached file xulstore.json

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:108.0) Gecko/20100101 Firefox/108.0

Steps to reproduce:

  1. Quit Firefox. Replace xulstore.json with attached one.
    This file is from my daily-use profile.
  2. Launch Firefox. Go to about:preferences#privacy -> click "Manage Data..."

or

  1. Run this in the Browser Console:
    Services.xulStore.setValue("chrome://browser/content/preferences/dialogs/siteDataSettings.xhtml", "SiteDataSettingsDialog", "height", "494");
  2. Go to about:preferences#privacy -> click "Manage Data..."

Actual results:

"Manage Cookies and Site Data" dialog is too tall.

Expected results:

The dialog should be resized properly.

mozregression:

2022-11-26T23:53:41.601000: DEBUG : Found commit message:
Bug 1779695 - Use modern flex on in-content pages. r=Gijs,dao,preferences-reviewers

This fixes the edit bookmarks dialog by properly allowing stuff to wrap once
the dialog width has been fixed.

Let's try to do this and opt-out any specific pages that may hit issues,
rather than opting-in one by one, now that's early in the cycle?

Differential Revision: https://phabricator.services.mozilla.com/D159690

2022-11-26T23:53:41.601000: DEBUG : Did not find a branch, checking all integration branches
2022-11-26T23:53:41.617000: INFO : The bisection is done.
2022-11-26T23:53:42.895000: INFO : Stopped
Attached image screenshot.webp
Component: Untriaged → Settings UI
OS: Unspecified → Windows 10
Regressed by: 1779695
Hardware: Unspecified → x86_64

:emilio, since you are the author of the regressor, bug 1779695, could you take a look? Also, could you set the severity field?

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

If we have frameHeight = 500px, minHeight = 800px and maxHeight = 600px,
we still need to make the dialog scrollable, otherwise the frame will be
too tall. This fixes the root issue, see following patch to fix the
issue specific to this page.

Assignee: nobody → emilio
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

This restores the pre-regression behavior for this dialog.

Depends on D163162

Probably not worth landing in this bug and should need some tests, but
if we don't we probably want to purge old XULStore values so that this
doesn't happen again?

Flags: needinfo?(emilio)

Set release status flags based on info from the regressing bug 1779695

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/126887ace592
Fix SubDialog with explicit height < min height > max height. r=dao
https://hg.mozilla.org/integration/autoland/rev/cd9de3a38edd
Fix XUL vs. flex layout difference in site data settings. r=dao
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch

The patch landed in nightly and beta is affected.
:emilio, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox108 to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

Comment on attachment 9305442 [details]
Bug 1802701 - Fix SubDialog with explicit height < min height > max height. r=Gijs,pbz

Beta/Release Uplift Approval Request

  • User impact if declined: Comment 0
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Relatively simple fixes.
  • String changes made/needed: none
  • Is Android affected?: No
Flags: needinfo?(emilio)
Attachment #9305442 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Attachment #9305443 - Flags: approval-mozilla-beta?
Blocks: 1803097

Comment on attachment 9305446 [details]
Bug 1802701 - Make attribute persistence work on subdialogs. r=Gijs,pbz

Revision D163165 was moved to bug 1803097. Setting attachment 9305446 [details] to obsolete.

Attachment #9305446 - Attachment is obsolete: true

Comment on attachment 9305442 [details]
Bug 1802701 - Fix SubDialog with explicit height < min height > max height. r=Gijs,pbz

Approved for 108.0b9

Attachment #9305442 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9305443 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Reproduced in Beta 108.0b7.
Verified - Fixed in Beta 108.0b9 and the latest Nightly 109.0a1 (2022-12-02) using Windows 10.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.