vanguard.com buying more shares form submission does nothing

VERIFIED FIXED in mozilla1.3beta

Status

()

Core
HTML: Form Submission
P2
normal
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: nick mitchell, Assigned: Alexandru Savulov)

Tracking

Trunk
mozilla1.3beta
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021030 Phoenix/0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021030 Phoenix/0.4

The new vanguard user-account page: when I try to buy more shares, it pops up a
window, i fill in amount and click next and nothing happens.  If I click on
Help, the help popup comes up fine. If I click Quit, then another Buy popup
comes up!! If I click Quit on that one, then another popup comes up asking if I
really want to cancel. I click Yes,and an empty popup come sup (except for Yes
and No buttons :D

I've emailed a report to Vanguard, but not sure if this is their bug our
mozilla's. Form submission seems fine with netscape 4.77 on linux.

Reproducible: Always

Steps to Reproduce:
1. log on to your vanguard.com account
2. navigate to account you wish to buy shares in
3. click "Buy", and proceed with odd behavior described in Details section

Actual Results:  
Next button does nothing, Quit button behaves strangely.

Expected Results:  
Next should proceed to a confirmation page. Quit button should ask me if I want
to cancel the transaction.
(Assignee)

Comment 1

16 years ago
nick,

we don't have an vanguard account to use for testing purposes. it would be
helpfull if you would try to investigate a little bit the problem. here is what
you can do:

- using the browser save the page source containing the form and attach it to
this bug report (see create new attachment) or (if the page contains sensitive
information about you)

- look in the source of the page for things like:

<input type=submit ... onclick="return wahtever_call(blah blah);">

then in the javascript thigs like: 

whateverformelementnameis.submit()

this might be the same bug like bug 138957. let us know please. thx!
(Reporter)

Comment 3

16 years ago
Created attachment 106384 [details]
view source for the buy popup window

Comment 4

16 years ago
I'm seeing exactly the same problem using 1.1 on Mac OS X:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826.
(Assignee)

Comment 5

16 years ago
nick,

i tested the attachment you made against a local server with a recent trunk
pull. (i just removed the <base> and the <link> elements from the source and i
changed the action of the form that contains the user data to reference my test
server).
AFAICT the data was posted correctly. could you please go and test again with
the latest build from:

ftp://ftp.mozilla.org/pub/mozilla/nightly/

this shouldn't be a trunk issue anymore. i don't know about the 1.2 branch,
probably we won't change anything on that anymore. thanks! 
(Assignee)

Comment 6

16 years ago
oh, forgot to mention: please use a trunk build.
(Reporter)

Comment 7

16 years ago
Heya, I just downloaded the mozilla-i686-pc-linux-gnu.tar.gz from
ftp://ftp.mozilla.org//pub/mozilla/nightly/2002-12-02-04-trunk

logged on to vanguard, and the symptoms persist, just as I described.
(Assignee)

Comment 8

16 years ago
damn! :-)

Comment 9

16 years ago
Is there any javascript errors when you try to submit?
(Reporter)

Comment 10

16 years ago
nothing on the javascript console. One more datapoint: when I click on the
"Next" button, nothing happens. When I then click "Quit", it pops up a new
window with the same contents (as I described in my first post). But if I click
"Quit" before clicking "Next", then I get the (expected) quit confirmation popup.
(Assignee)

Comment 11

16 years ago
vanguard uses pretty much the following way to submit:

<script>function do_submit(frm) { frm.submit(); }</script>
<form name=frm1 action=whatever onsubmit="return false;">
  <input type="submit" onclick="do_submit(frm1)">
</form>


we decided not to fire the NS_FORM_SUBMIT event anymore since it can break
important sites, and the reason it was put is still not implemented. so in order
to make important pages like this one work if they chose to submit nominating
for nsbeta1. 

i have the fix. 
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: nsbeta1
OS: Linux → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → mozilla1.3beta
(Assignee)

Comment 12

16 years ago
Created attachment 108983 [details] [diff] [review]
the patch

we remove the quirks mode check and submit synchronously in all cases in 
nsHTMLFormElement::Submit method, so the onSubmit event will not get fired
anymore. (that if it returns false in the unpatched version, will supress the
submission).
(Assignee)

Updated

16 years ago
Attachment #108983 - Flags: review?(jkeiser)

Updated

16 years ago
Attachment #108983 - Flags: review?(jkeiser) → review+
(Assignee)

Updated

16 years ago
Attachment #108983 - Flags: superreview?(jst)
Comment on attachment 108983 [details] [diff] [review]
the patch

sr=jst
Attachment #108983 - Flags: superreview?(jst) → superreview+
(Assignee)

Comment 14

16 years ago
fixed on trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

16 years ago
thanks everyone. i just downloaded the 2002121708 trunk, and it works!! 

Comment 16

16 years ago
verifying based on coments
Status: RESOLVED → VERIFIED

Comment 17

16 years ago
Using 2003010701/FreeBSD, <input type="button"> works,
but <input type="submit"> doesn't work.
Isn't this fix enough?

<input type="button"> works:
http://bugzilla.mozilla.gr.jp/attachment.cgi?id=1450&action=view

<input type="submit"> doesn't work:
http://bugzilla.mozilla.gr.jp/attachment.cgi?id=1451&action=view
You need to log in before you can comment on or make changes to this bug.