alt-d in German localization is not activating Datei

VERIFIED FIXED

Status

()

Core
Keyboard: Navigation
--
major
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: timeless, Assigned: Aaron Leventhal)

Tracking

({access, intl, regression})

Trunk
x86
Windows 2000
access, intl, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
This is driving me nuts. I don't care about the english localization, and I
don't care whose fault this is, but this needs to be fixed. It needs to be fixed
on the 1.2 branch, and I want it fixed by tuesday on the trunk.

Steps:
install de-AT (from url), it should work with your nightly
locale switch to it. in my build this doesn't require a restart -- the reason
i'm testing german is because i'm working on live locale switching.
press alt-d to trigger Datei (file menu). when it doesn't, get *very* irritated.
If nothing else, the accesskey should be coming from a DTD, not hardcoded. 
That's how all our accesskeys are done and this one should be no exception.  I'm
very tempted to back the patch out just on the basis of that, and I will, at
least from branch, if it's not fixed by tonight (because 1.2 should not ship
with this horkage).
Blocks: 157669
Keywords: access, intl, mozilla1.2, regression
(Assignee)

Comment 2

16 years ago
Created attachment 106397 [details] [diff] [review]
Use dtd for location bar accesskey

Seeking r=/sr=/a=
(Reporter)

Updated

16 years ago
Attachment #106397 - Flags: review+
(Reporter)

Updated

16 years ago
Attachment #106397 - Flags: approval?
Comment on attachment 106397 [details] [diff] [review]
Use dtd for location bar accesskey

approved for 1.2; lets get it in
Attachment #106397 - Flags: approval? → approval+
(Assignee)

Comment 4

16 years ago
Fixed in 1.2 branch. Waiting for trunk to open.
(Assignee)

Comment 5

16 years ago
checked into trunk
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
QA Contact: sairuh → ylong

Comment 6

16 years ago
Reporter:
It would be great that you can verify this on 1.2 branch and trunk build.  Thanks!

Comment 7

16 years ago
I can verify this on trunk (using my current L10n sources)

Comment 8

16 years ago
Created attachment 106740 [details]
error message when I launch the browser

With mozilla 11-18-08 trunk build:
After I installed the german language pack and selected it, I failed to launch
the browser.
That's because you need an updated locale pack (which no one but KaiRo has at
the moment).

Comment 10

16 years ago
There's a new Nightly XPI Pack on http://mozilla.kairo.at/ which should work for
new (trunk) nightlies, the key for address bar is Alt+S

Comment 11

16 years ago
I installed the language pack that mentioned above in 11-19-08 mozilla trunk
build (browser only).  The Alt-D works properly with open the file menu, as well
as some others, e.g. Alt-B, G, L, T ...etc.

I'm marking this as verified.  Please provide the language pack for 1.2 if want
to verify this on 1.2.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.