Fonts asked to display in italic, goes up rather than leans over.

RESOLVED DUPLICATE of bug 179667

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 179667
16 years ago
16 years ago

People

(Reporter: Loz Hygate, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021114
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021114

If a font is chosen (e.g. as my monospace font) that does not have a native set
of italic glyphs, and a page requires a monospace italic font then instead of
getting characters that lean over, I get an upward sloping baseline. 

Reproducible: Always

Steps to Reproduce:




This is Mozilla 1.2b, with the gtk-2.0 patch. I'm also using xft and font-config.
(Reporter)

Comment 1

16 years ago
Created attachment 106390 [details]
Example of misbehaving text

The font in the picture is Lucidia Console, It happens with others, though.
(Reporter)

Comment 2

16 years ago
Created attachment 106391 [details]
Example of misbehaving text

The font in the picture is Lucidia Console, It happens with others, though.
You want to get a non-buggy freetype.  See bug 179667 comment 10 

*** This bug has been marked as a duplicate of 179667 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.