Closed Bug 1804244 Opened 2 years ago Closed 1 year ago

[FxView] Firefox View page is updated only after a refresh while it’s being opened and Forget about this site option is used

Categories

(Firefox :: Firefox View, defect, P2)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
110 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox107 --- wontfix
firefox108 --- wontfix
firefox109 --- wontfix
firefox110 --- verified

People

(Reporter: atrif, Assigned: kcochrane)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-2022-mr1-firefox-view])

Attachments

(3 files)

Attached image fxview_02.gif

Found in

  • 109.0a1 (20221206034609)

Affected versions

  • 109.0a1 (20221206034609)
  • 108.0
  • 107.0.1

Tested platforms

  • Affected platforms: Windows 10x64, Ubuntu 20.04, macOS 11
  • Unaffected platforms: none

Steps to reproduce

  1. Open Firefox and open a random webpage (e.g Facebook) in a new tab and then close the tab.
  2. Open Firefox View.
  3. Open History and select the Forget about this site option for the Facebook page.

Expected result

  • Facebook page is no longer displayed in Firefox View.

Actual result

  • Facebook page is displayed in Firefox View.

Regression range

  • I will search for one ASAP.

Additional notes

  • Attached a screen recording.
  • Clicking the page inside Firefox View will make the link disappear. Clicking to dismiss the page inside Firefox View does nothing.
  • Refreshing the page fixes the issue.
Has STR: --- → yes
Whiteboard: [fidefe-2022-mr1-firefox-view]
Priority: -- → P2
QA Whiteboard: [qa-regression-triage]

Another scenario where Firefox View is not updated is when an already closed tab is Reopened. Here are the STR:

  1. Launch Firefox and in new tabs open Facebook and Twitter.
  2. Close both tabs and open Firefox View.
  3. Reopen the last closed tab via the context menu (right-click on the tabs bar -> Reopen closed tab) or using hitting the Ctrl/Cmd+Shift+Tab keys.
  4. Open Firefox View again.

At this point, the reopened tab is still present in the list of Recently closed tabs. For more details please see the screencast.

It seems that the issue is not a regression. I can reproduce it starting with bug 1762903 when the Firefox view tab was implemented.

Severity: S4 → S3
Assignee: nobody → bigiri
Status: NEW → ASSIGNED
Assignee: bigiri → nobody
Status: ASSIGNED → NEW
Assignee: nobody → kcochrane
Status: NEW → ASSIGNED
Pushed by kcochrane@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2acf2ea39486
Remove existing tabs in Recently Closed tabs list in Fx View if not found in latest closed tabs data r=sfoster

Need QA verification on this one please :)

Flags: qe-verify+
Flags: needinfo?(alexandru.trif)

Backed out for causing failures on browser_recently_closed_tabs.js

Backout link

Push with failures

Failure log

Failure line: TEST-UNEXPECTED-FAIL | browser/components/firefoxview/tests/browser/browser_recently_closed_tabs.js | Uncaught exception in test - at resource://testing-common/BrowserTestUtils.sys.mjs:1813 - TypeError: can't access property "ownerGlobal", tab is undefined

Flags: needinfo?(kcochrane)
Pushed by kcochrane@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/774891fa218d
Remove existing tabs in Recently Closed tabs list in Fx View if not found in latest closed tabs data r=sfoster
Flags: needinfo?(kcochrane)
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 110 Branch

Hello! Verified fixed with Firefox 110.0a1 (20230113094038) on Windows 10x64, macOS 11.5 and Ubuntu 20.04. The recently closed tabs are successfully removed from Firefox View after following the steps from comment 0 and comment 1.

Flags: qe-verify+
Flags: needinfo?(alexandru.trif)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: