Closed Bug 1804872 Opened 2 years ago Closed 1 year ago

reddit recap animation looks bad

Categories

(Core :: Graphics, defect)

defect

Tracking

()

RESOLVED FIXED
115 Branch
Tracking Status
firefox115 --- fixed

People

(Reporter: tnikkel, Assigned: tnikkel)

References

Details

Attachments

(3 files)

Goto https://old.reddit.com/RedditRecap2022 as a logged in user and scroll down.

I think this is probably a dupe of one of the open ChooseScale bugs.

(In reply to Timothy Nikkel (:tnikkel) from comment #0)

I think this is probably a dupe of one of the open ChooseScale bugs.

:tnikkel, is there a list of the bugs?

Flags: needinfo?(tnikkel)
Severity: -- → S3

The transform on the stacking context helper has the current scale, not the largest scale of the animation. The scale on the stack context helper holds this value thanks to the logic in ChooseScale.

Before webrender we would just look at the current matrix on the gfx context so it would have final size to draw at for the animation.

I have a fix that also fixes the blob recordings/image region case but it is a little more invasive so I want to land this first. The 3rd reftest will ensure that we can't turn on blob recording without fixing that case.

Assignee: nobody → tnikkel
Status: NEW → ASSIGNED
Flags: needinfo?(tnikkel)
Attached file rra.html
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f53842753805
Handle cases where a scale animation is being run on the compositor when choosing the size to get a decoded image at. r=aosmond

Backed out for causing reftest failures on 1553571-1.html.

Flags: needinfo?(tnikkel)

1553571-1.html uses a 1px x 1px div with a 256px x 256px image and uses a scale to scale it up to 140px, and then keeps tweaking the scale by a random factor of 0.01 to keep it as an active layer tracker actively scaled element.

This code

https://searchfox.org/mozilla-central/rev/ee6ab6eb2d222e0004604de62206baa67cac33af/gfx/layers/wr/StackingContextHelper.cpp#80

scales us up to the next power of 2 because for javascript controlled scale animations we don't know what scale to choose so we just round up to the the factor of 2. The patch in this bug means we actually decode at 256 x 256 (like the choosen scale is asking for) instead of ignoring that scale and decoding at 140 x 140.

Attachment #9328811 - Attachment description: Bug 1804872. Handle cases where a scale animation is being run on the compositor when choosing the size to get a decoded image at. r?aosmond → Bug 1804872. Handle cases where a scale animation is being run on the compositor when choosing the size to get a decoded image at. r=aosmond
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e7cdf4e16226
Handle cases where a scale animation is being run on the compositor when choosing the size to get a decoded image at. r=aosmond
Flags: needinfo?(tnikkel)
Regressions: 1834099
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 115 Branch
Blocks: 1688929
See Also: → 1689989, 1714763
Duplicate of this bug: 1688929
Regressions: 1834212
Regressions: 1834235
See Also: → 1806281
See Also: → 1792390
Blocks: 1834212
No longer regressions: 1834212
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: