Closed Bug 1805929 Opened 2 years ago Closed 1 year ago

Add a border to the minimonth calendar

Categories

(Calendar :: Calendar Frontend, enhancement)

Thunderbird 111
enhancement

Tracking

(thunderbird_esr102 unaffected)

RESOLVED FIXED
111 Branch
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: elijmitchell, Assigned: elijmitchell)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When first implemented, backgrounds of the minimonth calendar inside the Calendar context were removed for high contrast OS themes and situations where the OS theme is different from a set Thunderbird theme (light mode or dark mode). We need to use a variant of one of the theme colors to set a background for the calendar. It should not be transparent in these contexts.

The minimonth calendar is used throughout the application in places where a background is definitely needed for each minimonth displayed. It should not be transparent.

Inside calendar/base/themes/common/widgets/minimonth.css:

:root[systemcolors] calendar-minimonth {
  /* TODO: This should not be transparent */
  --mmMainBackground: transparent;
}

:root[lwt-tree]:not([lwt-tree-brighttext]) calendar-minimonth {
  --mmMainColor: var(--sidebar-text-color, FieldText);
  /* TODO: This should not be transparent */
  --mmMainBackground: transparent;
}
Type: enhancement → task
  • Distinguish minimonth calendar from its container and other minimonth calendars
  • Minimonth calendar should have a border in high contrast contexts
  • Evaluate if a background is needed in high contrast contexts (moved to bug 1811361)

Borders and backgrounds can distinguish between different calendars and make clear the boundary of a calendar versus its container's background.

The current designs include a border, but this border was not implemented in the initial UI updates to the minimonth calendar in bug 1799934. The border needs to be implemented.

Type: task → enhancement
Summary: Minimonth calendar should have a background in high contrast contexts → Add a border to the minimonth calendar
See Also: → 1811096
See Also: → 1811361
Attachment #9313547 - Attachment description: WIP: Bug 1805929 - Add border to minimonth calendar. → Bug 1805929 - Add border to minimonth calendar. r=#thunderbird-front-end-reviewers
Attachment #9313547 - Attachment description: Bug 1805929 - Add border to minimonth calendar. r=#thunderbird-front-end-reviewers → WIP: Bug 1805929 - Add border to minimonth calendar. r=#thunderbird-front-end-reviewers
Attachment #9313547 - Attachment description: WIP: Bug 1805929 - Add border to minimonth calendar. r=#thunderbird-front-end-reviewers → WIP: Bug 1805929 - Add border to minimonth calendar. =#thunderbird-front-end-reviewers
Attachment #9313547 - Attachment description: WIP: Bug 1805929 - Add border to minimonth calendar. =#thunderbird-front-end-reviewers → Bug 1805929 - Add border to minimonth calendar. =#thunderbird-front-end-reviewers
Target Milestone: --- → 111 Branch
Version: unspecified → Thunderbird 111
Target Milestone: 111 Branch → ---
Target Milestone: --- → 111 Branch

Pushed by alessandro@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/84cb958ae2cc
Add border to minimonth calendar. =#thunderbird-front-end-reviewers r=Paenglab,aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Duplicate of this bug: 1811361
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: