Download and save as dialogs should appear on the same workspace

RESOLVED DUPLICATE of bug 144250

Status

Core Graveyard
File Handling
--
trivial
RESOLVED DUPLICATE of bug 144250
16 years ago
2 years ago

People

(Reporter: Robert Holmberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a; MultiZilla v1.1.32y) Gecko/20021110
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a; MultiZilla v1.1.32y) Gecko/20021110

I'm using Gnome 2.0.2 with the Metacity window manager. When i click on a link
to a file I want to download and change the workspace I'm viewing, the download
dialog correctly(?) appears on the (new) workspace I'm viewing at the moment.
But when I click on the save button, the 'save as'- dialog appears on the same
window that the mozilla window I shift-clicked on is in. Since the download
dialog stays visible and *remains clickable* I can click 'save' for a number of
times and each click will spawn another save as window on that other workspace I
cannot see at the moment. This can be somewhat confusing at first..so the save
as dialog should appear in the same workspace as the download dialog.

Reproducible: Always

Steps to Reproduce:
1. Click on a link to a file that which will cause Mozilla to ask what to do
with it.
2. Quickly change workspaces (or send the download dialog to another workspace)
3. When the download dialog appears, click save. The save as dialog will appear
on the "wrong" workspace.
4. Click save some more to create more save as dialogs you cannot see.



Expected Results:  
Show the save as dialog on the same workspace as the download dialog. Perhaps it
should me modal too.
(Reporter)

Comment 1

16 years ago
Perhaps I should also mention that this is a gtk2 build from komodo.mozilla.org,
and that it appears without multizilla as well. 
does this problem still exist?
(Reporter)

Comment 3

15 years ago
I have been using the galeon 1.3 series lately, and my linux box is out with a
broken mobo at the moment, so I havent tried since last year and I can't try for
another few weeks. I'm also stuck on with a modem during summers, so I won't
download anything newer then 1.3.1, which I currently have. I'll try to remember
to test this as soon as I can, however. 

Comment 4

15 years ago
I have this same problem with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b)
Gecko/20030827 on RH9.
Assignee: asa → file-handling
Component: Browser-General → File Handling
QA Contact: asa → ian
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 6

13 years ago
Just tested this with Firefox 1.0.7 on Linux. The bug is still there if Firefox
is set to ask where to save every file. Its partially fixed in that the
"Opening" dialog now always appears on the same workspace as the Firefox window
that opens it. Still, if I move the Opening dialog to another workspace the Save
as-dialog appears on the original workspace with the Firefox window and I cant
see it as I press save. 

Since I now have to move the Opening dialog by hand to see this bug its unlikely
anyone would get confused about this.

Comment 7

12 years ago

*** This bug has been marked as a duplicate of 144250 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.