Closed Bug 180650 Opened 19 years ago Closed 19 years ago

Under OS/2, the character order of Hebrew coded websites is always reversed

Categories

(Core :: Layout: Text and Fonts, defect)

x86
OS/2
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bugzillamozilla, Assigned: mkaply)

Details

Attachments

(6 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.2b) Gecko/20021017

This problem applies to both logical coding (windows-1255) and visual coding
(iso-8859-8).

I have made some tests using both encodings and will attach the screenshots
after I post this bug. Here's a quick rundown of the results:

http://www.penguin.org.il - a logical Hebrew website.
Mozilla automatically detected the charset of the page and was set to render the
correct logical coding, but the result was a reverse order of the characters.
I then manually set the page to be viewed as visual coding - result: same
problem, but in addition, English text was now reversed as well.

The same test was performed with a visual Hebrew website, http://www.maariv.co.il
Mozilla detected the page properly and was set to view it as visual coding.
However once again, the characters were reversed.
Now comes the surprise, I set the coding to *logical* (windows-1255) and the
character order was correct.

* The title bars are always displayed properly.
* Writing Hebrew text is never handled properly (always from left to right
instead of the opposite).
* Phoenix 0.4 shows the exact same problem.

Reproducible: Always

Steps to Reproduce:
1. Install Mozilla 1.x on an OS/2 Warp4 machine with built-in Hebrew support
2. Open any Hebrew coded website, such as maariv.co.il and penguin.org.il


Actual Results:  
The character order of Hebrew text is reversed.
e.g. the word "מילה" is displayed as "הלימ"


Expected Results:  
The character order should follow the page charset.
e.g. the word "מילה" should display as "מילה"
To extract the archived screenshots, make sure to remove the .cgi extension first.
OS: other → OS/2
I'm viewing successfully several Hebrew sites regularly, and don't see this
anymore. I did in the past, but don't remember now what was done to change it.
(Whatever it was was the result of discussion with Mike Kaply in the OS/2
Mozilla newsgroup, and presumably is available in Google newsgroups.) Even after
the general display problem was solved, there remained the matter of the
displayed order of characters input to the web page, e.g. on
http://www.144.bezek.com/. That problem too is gone.
There are some preferences that override our settings for Bidi.

Could you see if anything make your system work?

There will be a file called all.js in your defaults\pref directory where
mozilla.exe is located.

Try changing bidi.support to 2 and see if that affects things.

Thanks.
Thanks for looking into this, Mike.

I tested ("bidi.support", 2) but I couldn't detect any difference with the way
Mozilla rendered these two pages (maariv.co.il and penguin.org.il)

Then I tried another pref, ("bidi.direction", 2) and it did have one positive
effect: Visual Hebrew pages are now rendered correctly. I will soon attach a
screenshot to show the difference.
Unfortunately, this makes the interface RTL (the menu-bar is aligned to the right).

All tests were performed with Mozilla 1.2.1 as well as the with the same build I
used when opening this bug.

Prog.
Can you please try this with a current build (create a new profile)

I don't see any of these problems.

Thanks
We're not seeing this on current builds. Please retest and reopen if you still
see it. 

Thanks
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
Sorry for the late update,

I've tested Mozilla v1.3 with a few Hebrew websites, and the problem has
actually worsened compared to v1.2.1.
As you can see from the attached screenshots, the new version not only gets the
character order wrong, but it fails to render most of the text. 

This is truly odd, since the latest Mozilla builds for other platforms work
very well with Hebrew websites (tested with Win32, OS X, Linux and BeOS).

By the way, v1.2.1 still works the same as last time, so I would rule out the
possibility of a regression in my OS configuration.

Prog.
Reboot your system and retry the testcase. Judging from what I see, you're in a
mode where Unicode is not functioning properly.

Also, what fixpak do you have?

We changed hebrew to use UTF8 (1208) for display. Maybe this isn't working on
your system.
Attached image Google Israel
Here is Google Israel as it is displayed on my system. The visual and logical
pages are not displayed properly, but I need to check my settings. Other UTF-8
pages with Hebrew text, as on http://www.mechon-mamre.org display perfectly
now.
I use the Cardo font.
http://www.haaretz.co.il/ is displayed very good as well
What's the problem with Google? It looks ok.
Attached image Google Israel #2
Thanks for the suggestions,

I'm running Warp 4.50 FP15 (Internal revision 14.062_w4). I also installed the
Cardo71s font and rebooted the machine, to no avail.

Anything else I should try?

Prog.
It looks like you were broken by my change to have Hebrew use 1208 for
rendering. Bummer.

I'm going to send you a new DLL to try (it will have to be tonight) and we'll
see what it does.
Here is the setting I use: Cardo is the 'serif' font, serif font is used for
display, other fonts are not allowed. This last setting makes maariv site
display properly as well.
Please download this ZIP:

http://www.kaply.com/work/hebtest.zip

It contains a new gfx_os2.dll.

Please replace the gfx_os2.dll in your 1.3 and see if it makes a difference.

Thanks
Thanks for the efforts.

With this DLL we're almost back at square one. Windows-1255 and visual
iso-8859-8 pages look the same as they did in 1.2.1 (ie. Hebrew text is visible
but reversed).
google.co.il (UTF-8) though, remains the same. With 1.2.1 it has slightly more
substance (for lack of a better word...)

I'm beginnings to think the a reinstall of the whole OS is in place :-\

Prog.
I'm happy that things are the way they were.

I don't understand why you see the problems you are seeing and other Hebrew
users don't.

I don't think a reinstall is in order though.

My fix to use 1208 to display Hebrew was done so Hebrew vowels would display
properly - some fonts don't work right with 1208.

What font were you using for Hebrew?
> I don't understand why you see the problems you are seeing and other Hebrew
> users don't.

Well, at least one of them did in the past, see Stan Goodman's input in comment #3.

As for the fonts, I tried the default ones configured by Mozilla (Times,
Helvetica, Arial and Courier) as well as various other combinations. I also
tested Cardo71s.

I also made sure that all the fonts under Hebrew, Western and Unicode include
Hebrew glyphs, but it doesn't seem to change much.

Should I try Microsoft's core fonts for the web?
http://sourceforge.net/project/showfiles.php?group_id=34153&release_id=105355

Could this be related to the version of OS/2 I'm running? I can safely guess
that most of you have updated your systems with CP1 or CP2 (or use eCS).
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.