Characters in the middle of strings are sometimes displayed in a much smaller font

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: miles, Unassigned)

Tracking

({platform-parity})

Trunk
x86
Linux
platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020913 Debian/1.1-1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020913 Debian/1.1-1

Occasionally in a run of text, a single character will show up in a much smaller
font; looking at the page source, the characters are in the middle of strings,
and not obviously distinguished (i.e., there aren't any tags or even whitespace
around them).

I've only noticed this with japanese text, and only on google (though it shows
up on various google pages).

I think it also has only shown up since I started using XFree86's truetype font
renderer (which usually makes japanese web pages look _much_ better).

Reproducible: Always

Steps to Reproduce:
1. Make sure you're using the environment as described below
2. View the web page give above
3. Look for any characters that look `odd'
Actual Results:  
A few oddly sized characters; I will attach an image file showing the problem

Expected Results:  
No oddly sized characters

Debian unstable

XFree86 4.2.1 (from the debian package)

Using XFree86's builtin font rendering (no font server)

Mozilla `Japanese' font selection set to `Take-kochi mincho-jis0208.1990-0' and
`Take-kochi gothic-jis0208.1990-0' (for serif/non-serif) @ 12-pixels size

Above fonts installed from debian `ttf-kochi-gothic' and `ttf-kochi-mincho'
packages (I also seem to have two more font packages with the same names, but
with `-naga10' appended; I'm not sure if this makes any difference)

Font path modified by adding:
	FontPath	"/usr/share/fonts/truetype/kochi"
to /etc/X11/XF86Config-4
(Reporter)

Comment 1

16 years ago
OK, I _won't_ attach an image file showing the problem, since bugzilla's bugs
prevent me from doing so... if anyone wants the image, just ask and I'll send it
via email.
Created attachment 106625 [details]
image from reporter

The reporter sent me this image by email.

Bugzilla requires cookies and may also not like it if your IP address is
constantly changing.
I'm actually seeing (with an Xft build) two sizes of fonts, but on much
different characters.  Perhaps there's something strange about the font
specified by this web page?
seems to be ok on win2k, although i'm not 100% sure as the characters are
unfamiliar to me. ->pp
Keywords: pp

Updated

16 years ago
Priority: -- → P3

Comment 7

16 years ago
Miles, can you reproduce this problem with a current version of mozilla? It
doesn't happen on my system, but I don't think I have XFT set up.

Comment 8

15 years ago
WFM, 2004-08-01-07 trunk Linux (and also WFM in an Xft debug build).

Miles, can you still reproduce the problem with Mozilla 1.7 or later?

Comment 9

14 years ago
Marking WFM due to no response from the reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.