Missing queryCharset in google.src

VERIFIED FIXED

Status

()

Firefox
Toolbars and Customization
--
minor
VERIFIED FIXED
16 years ago
12 years ago

People

(Reporter: Walter Wlodarski, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021102 Phoenix/0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021102 Phoenix/0.4

The Google search, in the Mozilla-search toolbar, doesn't provide the right
character set info to conduct proper searches in other characters set than
Western ISO 8859-1.

For exemple, a query in japanese doesn't work.

Reproducible: Always

Steps to Reproduce:
1. type japanese characters in the Google search toolbar (テスト)
Actual Results:  
Query interpreted by Google as if it was ???

Expected Results:  
Google results for テスト

A possible solution:

Adding queryCharset="UTF-8" in searchplugins/google.src

<search
name="Google"
description="Google Search"
method="GET"
action="http://www.google.com/search"
update="http://www.google.com/mozilla/google.src"
updateCheckDays=1
queryCharset="UTF-8"
>

Comment 1

16 years ago
-> asa
(ref: http://www.mozillazine.org/forums/viewtopic.php?t=789 )
Assignee: hyatt → asa
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Created attachment 107912 [details] [diff] [review]
Patch with the changes proposed by Walter

Updated

16 years ago
Attachment #107912 - Flags: review?(asa)
(Assignee)

Comment 3

16 years ago
Comment on attachment 107912 [details] [diff] [review]
Patch with the changes proposed by Walter

This seems to fix things. r=asa (for what that's worth).
Attachment #107912 - Flags: review?(asa) → review+

Comment 4

16 years ago
Asa, can you check this in?

Comment 5

16 years ago
Does not work yet on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a)
Gecko/20021207 Phoenix/0.5
(Reporter)

Updated

16 years ago
Depends on: 184360
(Reporter)

Comment 6

16 years ago
Influenced by bug 184360

Comment 7

16 years ago
See bug "Query charset searching on dmoz.org does not match with which dmoz.org
expects", http://bugzilla.mozilla.org/show_bug.cgi?id=186819.

Comment 8

16 years ago
*** Bug 188070 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
*** Bug 194096 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
Created attachment 116550 [details] [diff] [review]
Patch google.src to current version

Actually I've just looked at http://www.google.com/mozilla/google.src and it
was updated last October.  Here is the diff.  I think it should get synced.

Updated

15 years ago
Attachment #107912 - Attachment is obsolete: true

Comment 11

15 years ago
*** Bug 200770 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

15 years ago
yep
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 14

15 years ago
query in japanese works well.
v.
Status: RESOLVED → VERIFIED
Taking QA Contact
QA Contact: asa → bugzilla

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.