[PP] Linux - Bugzilla bug number query crashes browser

VERIFIED FIXED

Status

()

Core
HTML: Form Submission
P3
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: dave thorn, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build: 1999082316

Trying to query existing mozilla bugs causes the browser to crash.  Don't have
to select any search criteria, leave them as they are when the page loads (I'm
using PC, Linux) just click the "Submit query" button

from the output in my xterm:
<output>
Document http://bugzilla.mozilla.org/query.cgi loaded successfully
Document: Done (8.53 secs)
Assertion: "frame is not a valid child frame" (frames.ContainsFrame(aOldFrame))
at file nsContainerFrame.cpp, line 341
Break: at file nsContainerFrame.cpp, line 341
.//run-mozilla.sh: line 29: 20108 Segmentation fault      $prog ${1+"$@"}
</output>

Updated

18 years ago
Assignee: karnaze → kmcclusk

Comment 1

18 years ago
Reassigning to Kevin.

Updated

18 years ago
Severity: normal → critical

Updated

18 years ago
Assignee: kmcclusk → rods
Rod, this is probably another dup of the general crash caused by the re-creation
of frames.

Comment 3

18 years ago
Could this be a dup of bug 17431?
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

18 years ago
This works now - fixed

Updated

18 years ago
Status: RESOLVED → VERIFIED
Summary: Query Existing Bug Reports - submit button crashes browser → [PP] Linux - Bugzilla bug number query crashes browser

Comment 5

18 years ago
I saw this crash in the 19991109xx build on Linux, but not in the 1999111017 M11
build on the same machine. So, I'm verifying this as fixed.
You need to log in before you can comment on or make changes to this bug.