nsDependentCString filename(PR_GetEnv("MOZILLA_JS_PROFILER_OUTPUT")) => ASSERTION: nsDependentCString must wrap a non-NULL buffer: 'aPtr'

VERIFIED FIXED

Status

()

Core
XPConnect
--
trivial
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

({assertion})

Trunk
x86
Windows 2000
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
built with XPC_TOOLS_SUPPORT

nsDebug::Assertion(const char * 0x00341990 `string', const char * 0x003418a4
`string', const char * 0x003418ac `string', int 128) line 280 + 13 bytes
nsDependentCString::Rebind(const char * 0x00000000) line 128 + 31 bytes
nsDependentCString::nsDependentCString(const char * 0x00000000) line 174 + 47 bytes
nsXPConnect::nsXPConnect() line 82

    nsDependentCString filename(PR_GetEnv("MOZILLA_JS_PROFILER_OUTPUT"));
(Assignee)

Comment 1

16 years ago
Created attachment 106698 [details] [diff] [review]
patch
(Assignee)

Updated

16 years ago
Attachment #106698 - Flags: superreview?(jst)
Attachment #106698 - Flags: review?(dbradley)

Comment 2

16 years ago
Comment on attachment 106698 [details] [diff] [review]
patch

r=dbradley
Looks good to me, I'll be glad to get rid of this noise. Thanks.
Attachment #106698 - Flags: review?(dbradley) → review+
Attachment #106698 - Flags: superreview?(jst) → superreview+

Comment 3

16 years ago
*** Bug 174023 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

16 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: assertion
Resolution: --- → FIXED

Comment 5

16 years ago
Checkin verified -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.